SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Watch Folder not moving files on Synology Docker

I’ve been using Jaikoz for quite some time, but just bought Song Kong today, and I’m trying to figure it out. It’s quite possible my ‘issue’ is a user error.

I’ve played with SK on MacOS (for several hours before deciding to buy, and a bit after buying), but really think I’ll set it up in Docker on my Synology. With that in mind, I’m trying to set up a Watch Folder on my Synology install of SK. I’ve done this, and set values for the Move Folder and Move Unmatched Folder, and checked the boxes.

When I click start, it does it’s thing, (matching, fixing file/folder structure), except that it doesn’t move them to the Move Folder.

I’ve clicked on the Force Save option, too, to see if that helped. Doesn’t seem to.

Finally, when I click stop, and view the report, the Options tab shows the two Move folders as blank. This makes me suspect some kind of bug.

By the way, I’ve tried a similar (maybe not exactly the same) config on the MacOS version, and it’s working fine. This is unique to my Synology Docker install (or config).

I’ll try to upload screen shots (sorry, it’s a lot):

Screenshot 2024-06-10 at 8.17.55 PM

Initial values for Move and Unmatched folders…

I set them to what I want.

Here are the other values on that tab.

Here’s the save tab.

Then I click start and get this:

I drop an album folder in, omitting the Artist folder.

SK finds it and goes to work.

Then it goes FURTHER to work…

I gather this is because it created the Artist folder in the Watch Folder. Seems reasonable (considering the move isn’t working).

I hit Stop, and get this Summary. You can see it THINKS it saved and renamed (not sure if renamed includes the concept of “moving”)

Here are the Options it recorded. Note that Move Folder and Move Unmatched Folder are both blank.

Remaining options in case relevant.

So, on the filesystem side, the files were never moved to the Completed folder that I requested they go to.

Am I missing some checkbox? Or have some conflicting option set?

Thanks for any help. Again, this works on MacOS version. This is version 10.7…


Hi Jason, thanks for all the info but could you please run Create Support Files this will send not only the report but also your log files.

Hi Paul - I’ve generated/sent the support files. Neat feature!

Hi, it is a bug in the WebUI - it works okay in desktop mode, if on your mac you switched to using remote mode you would see changes made to these two settings in remote mode would have no effect.

Already fixed for next release.

On a Nas without desktop mode the workaround solution would be to manually modify the profile file


Modify the file

and set


Thanks Paul, the work around worked.
To clarify (in case others need this workaround before the update is released):

  • I updated the newest file named like* - in my case it was actually I’m guessing that each time the properties are updated it creates a new file? I haven’t used it long enough to note if it rotates them eventually.
  • When I started the process, it showed (in the webui) the values I’d entered in the properties file, and then when I dropped my test filefolder in the drop target, it did the expected thing.
  • It’s not clear how this would work if I made other changes to the config in the UI later, or if I cloned the config profile, etc.

I assume that the behavior is along the lines of reading the config, and then overriding that config with the submitted values, but that the bug is that it’s not even looking for that input during the parse stage (vs looking for it with a wrong name/id), else I would expect the work-around to fail.


There is one file per task profile, so the Default profile uses but if you create a new profile that would be and so on.

Yes, after selecting Start from the options page it parses the options but because of a bug it is ignoring the matched folder and unmatched folder settings and just using what was already set in the profile before you started the task.

Fixed in new release

Sounds great, and good timing - I just logged in because I didn’t see a new version of the container image available yet. I was gonna ask how the fix is going :slight_smile:

I’ll check back later (today / tomorrow / soon) to see if it appears. In the meantime, the workaround is still usable.

Should be new version of Intel Docker, have an issue with arm32 version not yet resolved.

There was an issue with Intel Docker build but that was resolved a couple of days ago.

Thanks - I’ve pulled the new docker version and confirmed it’s working. Thanks!

1 Like