SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

SongKong 6.11 Floodland released 16th November 2020


We are pleased to announce the release of SongKong 6.11 Floodland, named after The Sisters of Mercys goth masterpiece released in 1987.

This release is mainly small improvements and bug fixes.

Most notably we make some inprovements to the import of metadata from Naim Wav files. We fix an issue whereby Delete Duplicates would always stop if didn’t complete after one hour, made some improvements to the Delete Duplicates report and we handle some occasional issues with Fix Songs.


  • [SONGKONG-2088] - Linux:Move to Java 14
  • [SONGKONG-2106] - Naim UserEdits only does track mapping if have cddbinfo.txt or amginfo.xml file
  • [SONGKONG-2117] - Try and create artist artwork folder if parent exists instead of complaining it doesn't exist


  • [SONGKONG-2097] - Problems writing metadata for DSF files larger than 2GB
  • [SONGKONG-2098] - SongChangesReport:java.lang.NullPointerException
  • [SONGKONG-2101] - Melco: No files showing when start task
  • [SONGKONG-2103] - Duplicate record written to SongDiff table, looks like related to renaming file to duplicate
  • [SONGKONG-2105] - Invalid coverart error doesnt tell you what the problem file is
  • [SONGKONG-2107] - not starting in gui on linux
  • [SONGKONG-2108] - Delete Duplicates doesnt show fullpath of moved file so not clear which one is
  • [SONGKONG-2109] - Delete Duplicates doesnt load all songs, if takes more than 1 hour to load them all.
  • [SONGKONG-2112] - Double processing of files at Save stage related to DiscogsUpdate
  • [SONGKONG-2115] - Naim Matching, add to Errors and Warnings if unable to map from songs to cddbinfo.txt for some reason
  • [SONGKONG-2116] - Naim Matching, better parsing of filename when named as a multi-disc album

Hi Paul,
thanks for release of Floodland. Had similar hang experience to what happened in April so have sent you support files from last night’s Fix Songs run. Could you let me know if you have received, and if there is anything I can try?
many thanks again for your help,

Hi Paul
I just got the message - New version 6.11 is available, please install from Melco OLED
However when went to update from the OLED I got an error 040 code and the message - updater not found
Not sure what the issue is

Can you help please? BW


Hi Karen, okay I have received the logs and the issue does look similar. The issue is very much specific to Melco, my longer term plan is to rework how the internal database works (basically simplify it so it uses and I think that will solve it, but that is a big task. But I have exhausted the avenue of specific tuning changes for Melco so Im afraid I dont really have a solution for you at the moment but I hope the work SongKong has already done has improved your music collection significantly. If you want to fix particular album it should work fine, the problem only comes when running against the while (or large part) of your music collection.

Hi Paul - ok I understand and no problem. But, I have mucked up as I did not run as preview and for some reason I cannot now access any songs :frowning: Is it possible to undo what I have done…? If I run “Undo Fixes” will this unravel what I just did, even though I cancelled out part-way through?
sorry for hassle, thanks again,

@Karen If you start restart your Melco and wait five minutes should be okay.

Hi mark, please check you don’t have a songkong.test file lying around, see How do you install Melco SongKong Test Version for reference.

There will be such a file - can you tell me how to deal with it please? M

Just delete it, and then updater should work.

Yes I tried, but MinimServer is not coming back on line at all… So I cannot get to anything on the Melco App. Is “Undo Fixes” a way forward, or perhaps another Fix Songs run but unchecking what I tried to add on the Artist Artwork?
Sorry for hassle Paul.

The issue with SongKong should not affect MinimServer, but you do need to run rescan for MinimServer if you have made changes.

It is worth noting that MinimServer indexing takes a while to complete. The OLED message can be misleading and make you think it has completed indexing when it is still running, please see Update MinimServer after fixing with SongKong for more details.

Hi Paul - it seems more serious than that. I cannot access MS at all now via the OLED or Mac or IP address. The “Browse Songs” option on the Melco OLED is “–” so I think my MS has somehow got corrupted. Guess I may need to try a re-install?
[I left the Melco on all day today before restarting control point, to see if reindexing was the problem, but still no joy.]
thanks, Karen.

hmm, i think you should post question on the MinimServer forum where Simon will be able to help you better than me.

Thanks Paul - Simon has told me how to do a reset on MS2 so all sorted now.
Thanks again,