SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

SongKong damaging metadata for files >2GB

I have some large (>2GB) multichannel flac and dsf files and if SongKong saves the files, all of the normal metadata (Album, Artist, Title, TrackNumber, etc.) gets erased. This seems to be a problem only for files exceeding this threshold.

Hi, there did used to be an issue with files >2gb but this has been resolved, but yo may be encountering a different issue.

When you say

all of the normal metadata (Album, Artist, Title, TrackNumber, etc.) gets erased

are you saying that the advanced metadata doesn’t get erased, or do you just mean all metadata has gone, is it missing when you reload the songs in SongKong or only missing when you view the fiels with a particular app ?

Does the audio continue to play ok ?

Hi. A few clarifications:

  1. As it turns out, all of the affected files are .dsf. I don’t have any FLAC files affected by this issue.
  2. It appears that any tags I have asked SongKong to update are correct. It is the tags I told it not to touch that get erased. In my case, the configuration is to add all identification related tags (MusicBrains, Discogs, and AcoustIDs) and not touch anything else.
  3. The files still play fine.
  4. I am currently using version 6.10.0. I have not updated to 6.10.1 because nothing in the release notes seems to affect my situation.

Thanks

A couple more clarifications:

  1. The missing metadata does not show up in the SongKong reports (The new tags show up, there is nothing in the Unchanged section for these files. Other files in the same directory from the same album that are <2GB have their existing tags show up in the Unchanged section.
  2. The tags are missing in every program I’ve tried (mp3tag, dbPowerAmp, my own software, Roon)

Thanks

Could you please run Create Support Files so I can examine your report and give me some specific details of what fields are now missing.

Hi, support files have been sent with a single album run. Here are some images showing before running fix, after running fix, and then after running undo:
Before Fix:


After Fix:

After Undo:

Hi

So Dsf uses ID3 tags just like Mp3 using the ID3v23 or ID3v24 format. Now the missing fields can also be stored using the older ID3v1 format and I wonder if dbPoweramp is always expecting those fields to be stored in the ID3v1 format but SongKong is now only storing those fields in the ID3v2 format. Not sure how this relates to >2GB,

Does your music player see these basic fields or not ?

Is there any chance you have the original file before it was modified by SongKong and could upload (using Dropbox or similar) it for me to test it out. If not I can try and generate a test case to see if I can replicate the behaviour and then fix it, I am well aware it is a large file to upload but would be much easier for me to start with a testcase that I can use to generate the problem.

Hi there. The tags are gone with everything I’ve tried. Here is a picture of the folder from mp3tag:


Note the four files with no tags. Those are the ones bigger than 2GB. I have uploaded one of them to google drive but couldn’t seem to figure out how to send a private message. If you send one to me I will reply with a link.

Thanks

The issue is now fixed in the underlying jaudiotagger library. If anyone needs this fix urgently for SongKong or Jaikoz they can build the lib and then replace jaudiotagger lib with the new one, otherwise this fix will be available in next releases of Jaikoz and SongKong.