SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Linux startup difficulties

Hey there,
I’m a bit confused.
On the download site ( I can only find a headless version of songkong for linux.
Is there a desktop version as well, and where could I find it?
Beste wishes

Sorry for the confusion, now it simply means the installer is headless and doesn’t require you to have gui access (Xwindows) to install. Once installed the application can be run as desktop app or server app.

Thanks for the quick reply!
I downloaded songkong and unpacked the archive, but when I run ./ -g I get:

/ -g
debuglogfile is:/home/samuel/.songkong/Logs/songkong_debug%u-%g.log
userlogfile is:/home/samuel/.songkong/Logs/songkong_user%u-%g.log
Nicht erfasste Optionen für SongKong
Einstellungen für SongKong sind wie folgt:
Usage: songkong [options] file1 file2 file3 ...
       delete duplicates in specified files
       Default: false
       run in gui
       Default: false
       show usage information
       Default: false
       fix songs in specified files
       Default: false
       run in remote mode, access via browser (i.e http://localhost:4567)
       Default: false
       create status report for specified files
       Default: false
       undo any changes made to songs in specified files by SongKong
       Default: false
       watch folder in specified folder
       Default: false

I’m not sure what file1 file2, etc means. I tried giving a music file or a music folder as arguments, but the result is the same.

Thanks a lot for your help!

You only pass music files folders when not running in normal gui mode, what happens when you just run


I get the exact same output.

And you have Xwindowing ?

Can you post actual screenshot please.

I’m running on Xserver, if you mean that.

Here is a screenshot:

Here is the debug log:

The user log remains empty.

Sorry to bother you. But do you have any idea, how I could start songkong?

Sorry, I’m hitting same problem myself but havent yet established why.

But in the meantime please try remote mode using -r and then you can use the web interface by opening web-browser and pointing to http://ipaddress:4567

Thank you very much for your help. That works for the moment.

1 Like

Found the issue, the problem is caused trailing DOS eoln character, my main dev machine is Windows and I must have inadvertently introduced a ^M by editing the file on WIndows.

The problem is fixed by editing in vi (or other unix text editor) and removing the ^M character at end of line, it will be fixed in SongKong 6.11 which will be released this week.

Now fixed in SongKong 6.11