SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Jaikoz 10.1.0 Pavement Released June 26th 2020 for MacOS

We are pleased to announce Jaikoz 10.1.0 Pavement is now released (yes now naming new releases after some of my favourite bands) for MacOS, it will be available for other platforms shortly once we have resolved an issue with installer.

This is a consolidation release that aims to bring Jaikoz up to date, subsequent releases will have more new features.

Major MacOS Changes

We now support Dark Mode

and Apple Music App

and MacOS Notarization

Metadata Tagging

New version of tagging library containing over forty fixes for reading and modifying audio files.

Java Changes

We have moved from Java 8 to Java 11, this provides many fixes and improvements delivered with Java 11. It also means that we can provide a smaller Java Runtime containing only the libraries that Jaikoz needs

Note Java 11 also means we no longer support Windows 32bit, since this is not available with Java 11

  • [JAIKOZ-1189] - OSX:Issue with About and Quit handler
  • [JAIKOZ-1202] - MacOS:Formatting of some Preferences tabs not quite right
  • [JAIKOZ-1215] - MacOS:Quit Handler Exception
  • [JAIKOZ-1218] - Removal of Lock on Save can cause problems with M4as because can use temporary files.
  • [JAIKOZ-1239] - Not respecting Only allow match if all songs on album are matched option when matching directly from MusicBrainz
  • [JAIKOZ-1249] - MacOS:Cannot configure Player app because chooser doesnt let you select Application folders
  • [JAIKOZ-1251] - Fixes for Music Tagging Library
  • [JAIKOZ-1265] - MacOS:iTunes Add New Tracks sometimes complaining nexttrack not defined


  • [JAIKOZ-887 ] - Add way of marking Tracks as Instrumental
  • [JAIKOZ-1184] - OSX:Font size on detail panel only smaller than it used to be
  • [JAIKOZ-1237] - MacOS Mojave and later:Add Support for Dark Mode
  • [JAIKOZ-1252] - Update to Java 11
  • [JAIKOZ-1253] - MacOS:Add support for stricter MacOS Notarization controls
  • [JAIKOZ-1254] - MacOS:Add Support for Music app instead of iTunes
  • [JAIKOZ-1255] - Remove support for Windows 32bit version
  • [JAIKOZ-1257] - Build custom Java runtime with only the classes needed
  • [JAIKOZ-1262] - MacOS:Remove Cross-Platform option for MacOS
  • [JAIKOZ-1263] - Move to latest version of OneMusic Image Archive
  • [JAIKOZ-1264] - MacOS:Preferences:MusicBrainz:Format is not formatted correctly on MacOS

Just tried to install the new version on Win10-64, and it failed. Details of error:

com.izforge.izpack.api.exception.IzPackException : An error occured

  • in java.lang.Thread. run () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. run () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. unpack () at

Caused by: java.lang.NullPointerException : null

  • in com.izforge.izpack.installer.unpacker.UnpackerBase. unpack () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. unpack () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. unpack () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. unpack () at
  • in com.izforge.izpack.installer.unpacker.UnpackerBase. extract () at
  • in com.izforge.izpack.installer.unpacker.LooseFileUnpacker. unpack () at
  • in at

I got the same error. Do you first have to upgrade Windows manually to Java 11?

I think I have fixed the problem, please redownload and retry.

That is not required, assuming you had an old version of Jaikoz already installed can you try manually deleting C:/Program Files/Jthink/Jaikoz and then installing to see if that solves the issue.

I get a very similar traceback (not quite identical) when attempting to upgrade on Linux too.

com.izforge.izpack.api.exception.IzPackException: An error occured
in at
in at
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at
Caused by: java.lang.NullPointerException: null
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at
in com.izforge.izpack.installer.unpacker.UnpackerBase.extract() at
in com.izforge.izpack.installer.unpacker.LooseFileUnpacker.unpack() at
in () at

Deleting the old installation first made no difference.

Okay I have now managed to replicate the issue on another PC., but it is not clear to me why it is happening on this PC but not the other one. Since Windows and Linux use the same installer software I have temporarily rolled these releases back to Jaikoz 10.0 until the problem is resolved. Jaikoz 10.1 is still available for MacOS but if you are using an earlier version of Jaikoz on MacOS you will not for the moment receive notification that Jaikoz 10.1 is available.

In case it is relevant, the system Java version attempting to run the installer is

$ java --version
openjdk 11.0.7 2020-04-14
OpenJDK Runtime Environment (build 11.0.7+10-suse-lp151.3.16.1-x8664)
OpenJDK 64-Bit Server VM (build 11.0.7+10-suse-lp151.3.16.1-x8664, mixed mode)


This keeps crashing on launch 10.15.1, fresh install - just found out about this app today but can’t use it :frowning:

I can submit a crash report or two from if there’s somewhere to send since I can’t access the bug reporting tool in app

Do you have an external monitor connected ?

Yes, is that an issue? (Note I’m on a Mac Mini so technically all displays are external, but there are multiple external displays. not sure if that differs from a portable or if it’s a numbering thing - figured more information is better than less here)

Yes, just discovered it is a recent Java/Apple bug,

This has now been fixed in Java 11.0.9, but it is not yet available, as soon as it is I will update Jaikoz to use it.

You are right about MacMini, I have now seen problem on MacMini with single monitor, but only when it switches between TV and Mac. You could for now use the previous version using this link -

1 Like

Much thanks for the prompt response / link.

Thanks, It worked fine this time.

I take that back. The installer worked fine, but it simply re-installed 10.0.

Yes that is what the Mac link is, previous version. Because I cannot release a Jaikoz fix for this issue until the fixed version of Java is available.

I’m downloading the Windows version, and it’s installing 10.0.

Right, on the download page it clearly says due to a problem with Windows and Linux installers we have gone back to 10.0 for these platforms until can resolve this. It’s difficult to solve, on my main Winows machine it works fine, but fails on another Windows 10 machine.

There is currently an issue for MacOS if you have an external or multiple monitors this can cause a crash. This is a bug in Java that has been resolved in Java, we are waiting for this new Java version to be released to resolve this in Jaikoz, if this is causing a problem for you then you can use Jaikoz 10.0 until the issue is resolved download here