SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Unable to open songs in SongKong

I have problem which has occurred a couple of times before. I can open SongKong on my PC and remotely on my iPad, however when trying to select a music folder it initially takes longer than usual ~10-15 seconds but then when the folder opens there are no songs in it. I rebooted my PC which didn’t resolve the issue. I’ve not tried rebooting my Melco yet and thought it worth highlighting this with you. Thanks.

In respect of the above, I can also report that albums play with no problem through my control point.

Can you see the files from your PC in Windows Explorer, have you mounted your Melco drive as a remote drive (i.e. Z:drive) , if so best to use this in SongKong rather than the \ syntax.

Yes, I can see the files/tracks through the Z drive, which I set up when I bought the Melco and SongKong (over a year ago). When I wish to open SongKong to fix songs I use Google Chrome with usually no problem. I have now rebooted the Melco, but still on opening SongKong the file/album opens, but there are no songs listed at all.

Okay I think you mean are using the remote interface to connect directly to the Melco, and the start windows shows icons along the top and a folder tree but no files ?

This is correct, as the point is just to allow you to select a folder on the Melco to process, files are not shown.

If this isn’t what you are doing, please post a screenshot.

Two shots attached. I’ve rebooted my computer this morning and still no access to songs.

. I also sent screenshots yesterday via the email you sent. Thanks.

Okay screenshots help. So the first screenshot is fine because as I explained it the folder browser is only intended to show folders. But if SongKong lets you open a folder for manual edit it must have found some files and therefore should show the files - so the the second screenshot indicates a problem.

Please select the Create Support Files option from start page to send me your logs.

Rebooting your PC is going to make no difference since you are just using your PCs web browser, the problem is on the Melco, either with the files or with SongKong itself.

Thanks Paul. Support Files uploaded. Just as a reminder from my first post, the same thing happened about 2 weeks ago but seemed to resolve itself with no specific action from myself, if that helps. I would also add that occasionally I cannot open SongKong from the web browser at all, but again it seems to resolve itself, and so has not needed me to post the problem to the forum. Thanks.

okay, there is a database issue and I also wonder if you have filled up the part of your Melco hard drive reserved for applications (SongKong and MinimServer)

Please do the following:

  1. Stop SongKong from Melco OLED
  2. Connect to the SongKong folder within Logs folder
  3. Delete the Database, Logs and Reports folders
  4. Restart SongKong from OLED
  5. Wait a few minutes for SongKong to restart then see if that resolves issue.

I’ve turned “SongKong Service” Off on the Melco, if that’s the first step.
Is Step 2 done on PC? I’ve tried to open SongKong from the browser and I have the message “this site can’t be reached”, so can’t open up SongKong.

O.K. I see now from the directions given for each point that I have correctly stopped SongKong. However, I don’t seem to be able to find the logs folder. I have gone to the Map network Drive tab and selected (I assume correctly the Z drive for the melco). However, I does not give me the folder drop down options, as per the example in the notes: it only gives “Network” in the folder selection options, with no further access. Have I done something wrong?

Step 2 is a hyperlink (cant you see that it is a hyperlink? ), that clearly explains what you have to do, for Melco EX logs is a different folder to the music folder

Yes, I was using the hyperlink for step 2 but as explained in my post I don’t seem to be able to select the drive/folder as per the instructions in the map network drive tab.

Am I right in assuming that you have managed to connect to your melco to browse the music files before, and you have a Melco EX, N10 or N100 ?

In which case you are just connecting to a melco drive the same way as before, but instead of selecting the Internal folder (where trhe music is stored) you select the logs folder.

Or are you using an N1 that has not been updated to EX ?

Yes, I have the N1A EX. I see what you are saying, but I only appear to have the Internal folder, I cannot see where to access the Logs folder. I’ve attached a screenshot if it helps.


Okay so at some point you connected to the Melco Internal folder, successfully. I’m asking you to repeat the process but this time connect to the Logs folder, so in your case you end up with two Melco drives , one pointing to the Internal folder (for music) and one pointing to the Logs folder (used by SongKong and MinimServer)

You cannot access the Logs folder from your existing Internal drive because Logs and Internal are at the same level, Logs is not within Internal.

I understand what you are saying, but exactly where are the logs folders and how do I access them? Thanks.

OK, I’ve found the logs folder (via the Minimserver User Guide) and deleted the folders as requested. Re-started SongKong on the Melco and waited five minutes. Unfortunately, as before, the tree folder with all albums is displayed, but when trying to open a specific album no songs are displayed??

The link explained exactly what to do with screenshots - I don’t really know I could have made it easier, did you actually read it ?

Okay, that is suprising can you send the support files again.