SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Unable to connect to SongKong on Melco via browser

I have just upgraded to Floodland on my Melco N1A-Mk2 and now have the same problem. Have checked Songkong service is running and using correct URL. Have tried from Safari, Chrome and an iPad. Have also confirmed can still link to Melco from Mac in Finder and by running Melco from Mac. But cannot link through browser - any ideas?

Hi. doesn’t make any sense to me this, perhaps you could send a few screenshots so I can see the details.

Hi Paul, Let me know what screenshots you want, and whether you want them sent by e-mail or posted to the forum.

Easiest if you post to forum, if they contain personal info you dont want to be public then just use the forums private messaging facilty. My suspicion is you are entering incorrect url so please post screenshot of browser when accessing SongKong.

Are you using MinimServer as well if so could you try and connect to MinimServer via browser as well.

I agree it should be obvious but I cannot see it. Here are various screen shots…


In the first image you can see that Safari cannot connect to 192.168.0.54. In the second you can see Finder connected to that address and Songkong running against the Melco fine. I also am copying the file from front of Melco…

Can you connect to MinimServer from browser ?

Hi, I tried on x.x.x.x:9790 (think that is correct) but not accessible - same as Sonkong

So it seems your issue is related to your Melco/network rather than specific to SongKong.
If you go to the OLED and do System Update:Internet does it work or give an error ?

Maybe try Network:Settings:LAN Port:DHCP to see if your Melco can access the network

When doing System Update:Internet I get “That update has already been applied”

When doing Settings:Network:LAN Port:DHCP it simply says “Finished”

I have established that I can see the device from my Mac on port 9050 (Twonky?)

Has the ipaddress changed, can you retry SongKong now ?

The IP address did not change and can still not access SongKong port.

But as I said, can access Melco via port 9050 (Twonky?)

Sorry I should have made that clear.

And have you tried restarting the Melco. If SongKong is running and the Melco is assessible I can’t think of a way you would not be able to connect via browser, but rebooting may sort it out.

Hi. I have restarted Melco. One thing I notice is that on “Songkong Service” there is an asterisk beside “Off” regardless of which I select, i.e. this picture is taken after selecting “On” and letting Melco cycle through to say “Finished”.

Am I interpreting this correctly that Songkong Service is not switching on or is that not what asterisk means.

Correct, that means it is not starting, but why would that be.
Can you connect to your Melco drive from your computer - and send me the contents of the Logs folder please.

I do not see a Logs folder - am I looking in right place?

When I locate it how do you want folder sent?

Sorry if previous post was wrong - did you mean run Songkong from Mac and “Create Support Files”?

I think I have found the Logs file on the Melco. Songkong has moved it under some music folder. (Also a lot of .tmp files I’m wondering if I can delete). Anyway, here is the structure. Let me know what you want me to send and how to send it.

Thanks,
Ian

Did you read the link?

The SongKong files on the Melco do not reside in the same location as your music files, please reread the link.

We are interested in the Songkong files on the Melco, Songkong on your computer is irrelevant to this issue.