SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Track and Discnumber padding -- Problem wih Filename Mask

Hello,

i am using the Plex filename mask to keep everything simple. For multi-disk albums the filename should be like this:
101 - Tracktile.flac
If Track and Discnumber padding is activated it looks like this:
0101 - Tracktitle.flac
If i deactivate the Track and Discnumber padding in fix songs everything looks fine.
If i edit the metadata manually the Track and Discnumber padding is again applied.

Is there an Option to deactivate the Track and Discnumber padding on manual edit?
As an alternative solution: Is it possible to remove the Discnumber padding at the rename mask?

Thanks for support.

Hi, I tested this and could not make this problem occur. I manually modified DiscNo changing DiscNo from 01 to 1 and that value was maintained regardless of what value had Disc /Track number padding set to in Fix Songs

If that is what you meant please run Create Support Files so i can see this, or do you just mean it is still padded in the filename (rather than the DiscNo field)?

So this is the content of the Plex mask

ifnotempty(albumartist,'/')
+ ifnotempty(album,'/')
+ ifmultidisc(discno)
+ ifnotempty(pad(trackno,2),' - ')
+ title

So it doesn’t pad discno but it does pad trackno, this is what you want.

So Im not sure of your problem best if you send support files.

Thanks for the answer. The Problem is not the filename mask, the problem is that the discnumber gets automatically padded in the Tag when performing manual correction in SongKong. When performing Fix Songs there is the option for disabling the padding. That is not the case when performing manual correction, as far as i can see.

Okay i tried that and it doesnt pad for me so please send support files so I can see your results.

Ok, i will check again later. Thanks

Tried again and i can reproduce the problem. Just sent the log files.

Hi Chris

Found problem, it only happens when using remote Web UI, it doesn’t happen on Desktop UI and I was using Desktop UI before, raised bug

Now, because you are using docker version you have to use Web UI so what is workaround?

  • Stop SongKong container
  • In the real folder mapped by virtual folder /songkong there should be a file called songkongedit_songs.properties, open for editing
  • Add line numberPadding=0
  • Save file
  • Restart SongKong

That should now resolve the issue, so discno/tracknos saved to match what you entered in the webui.

I assume the underlying issue is you want trackno to be padded but discno not to be padded, so if we had separate option for discno padding and trackno padding then you could set accordingly, I have reopened issue for this

We could also do something to the filenamemask so that it removes zeroes from discno, raised another issue for this.

That makes sense. I will have a look at your workaround.
The option of only padding the trackno would be good.
In the meantime i could also use jaikoz for manual edit, but it is really convenient to use only the Web UI.
Thanks for taking care.