SongKong and Jaikoz Music Tagger Community Forum

Songkong Installer now available for Melco N1 Mk1 and and N1 Mk II Models

SongKong was already available for the newer Melco models, but it now available for N1 Mk I and N1 Mk II models via the OLED installer. The only difference is the firmware required currently needs to be installed via USB rather than over Internet but once that is done SongKong can easily be installed from the Front Panel OLED

  1. Select Settings/Music Database/SongKong/Install SongKong from the Melco OLED
  2. Select OK when prompted to Install SongKong
  3. The OLED will say Install in Progress , wait a few minutes for SongKong to download and install SongKong
  4. Select OK when OLED says SongKong was Installed
  5. Select Settings/Music Database/SongKong/SongKong Service
  6. Set to On
  7. After first install please wait 5 minutes before trying to access SongKong

Full details at http://www.jthink.net/songkongformelco/melco_install.jsp

I attempted the Melco N1 MK2 firmware 392b update today with two different usb drives and followed the directions on the link for the install. Both times it came up “Updater not found Error 041”.

You need to insert the usb stick into the one marked USB, not the one marked Expansion or Backup
Did you unzip the the download and just copy the file directly to the USB stick ?

Hi Paul,

I did insert it into the USB port.

I downloaded the file and then opened the two files in the download.

The one named binary bin has two files in it. I copied only those two onto the jump drive, which I then inserted into the rear USB port on the Melco.

Thanks,

Robert

There is only one file not two

Do I open the binary bin file before I copy it onto the USB?

I tried various ways after downloading the file multiple times, and always the same “Updater not found. Error 041” comes up.

You open the folder and then just copy the .bin file onto the us stick , you don’t open the bin file

Perhaps take a screenshot on Windows of the usb stick contents and I can tell you if done correctly.

Here is one showing the download, which I copied into the USB on the right.

will follow with another.

That’s wrong you have copied the folder to the usb stick, you need to just copy the file in the folder

Here is another attempt. I tried several ways all with the same result.

I tried again with a new download just copying the bin file to the USB. Same error result.

Hi, both screenshots you have sent so far are wrong, if this one is different please send. Sorry I’m out at moment so I can’t send screenshot of what it should look like.

Here is the last one I tried.

Why has the name of the file changed !

The file is copied into the USB stick with the name Song Kong.
Otherwise, it is the same as when I opened the download.

Below I have put step by step instructions for copying the file to your USB stick

  • Download from link so file gets downloaded to your browser downloads folder

  • Unzip the zip file created

  • Go into the folder created

  • Go into the subfolder

  • Copy the audionas_ha_n1_updater.bin to your USB drive so your USB drive looks like

  • Now put this USB drive into your Melcos USB port, and do System Update from USB

Thanks for the detailed instructions. I will follow up tomorrow morning (currently 1:30 am ).
I will let you know on the result.
Robert

1 Like

Great job Paul!! the update worked flawless and I enjoy SongKong on my Melco N1 now.
I would wish that the update towards MimServer2 would be that easy too.

Ah, one last question: the SongKong BETA code is being removed with this update?