SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

SongKong freezes

Hi there!

I started using SongKong version 6.10.1 Odelay under Windows 10 Pro build 19041.572 a few days ago. SongKong license is valid. Java is updated.

Tests of “Fix Songs (fix from naim wav metadata files only)” as “Preview Only” worked well. But once I uncheck “Preview Only” and start the task, SongKong freezes after a few songs. That’s it. It will not even finish one album… :frowning:

I paused anti virus and VPN, but this doesn’t seem to have any influence. Any idea or advice on this?

Thanks & Regards


Hi, try File:Empty Database and then rerun Fix Songs. If that does not work please run Create Support Files so I can examine your SongKong logs.

Hi Paul,
thanks for your fast reply.
Just arranged transfer of the support files. I needed two attemps, hope it is okay… :slight_smile:
Thanks & regards

ups, just got a message from SongKong that files couldn’t be sent…
I tried again. Seems okay now.

So I can see Report 15 Preview finished 08:47

20/10/2020 08.47.03:CEST:CmdLogger:log:SCHWERWIEGEND: Songs Report is:C:\Users\izuck\AppData\Roaming\SongKong\Reports\FixSongsReport00015\FixSongsReport00015.html

then you started new run at 12:54

20/10/2020 12.54.03:CEST:FileMapping:configureBaseFolders:WARNUNG: CheckingFolder:E:\naim music\19.10.2020

but nothing happened after 12:54:19

20/10/2020 12.54.19:CEST:StartMatcher:<init>:SCHWERWIEGEND: G50:E:\naim music\19.10.2020\aussortiert\Greta Van Fleet\Anthem of the Peaceful Army:false:false:false:false

then you retried at 20:18 seem to hang again

then retried again at 2:37 but looks like resources were not released so caused this error

22/10/2020 14.37.42:CEST:WARNUNG: com.mchange.v2.resourcepool.BasicResourcePool$ScatteredAcquireTask@289a2e2f -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (10). Last acquisition attempt exception: 
org.h2.jdbc.JdbcSQLNonTransientConnectionException: Datenbank wird wahrscheinlich bereits benutzt: "Locked by another process". Mögliche Lösungen: alle Verbindungen schliessen; Server Modus verwenden
Database may be already in use: "Locked by another process". Possible solutions: close all other connection(s); use the server mode [90020-199]
	at org.h2.message.DbException.getJdbcSQLException(

But other than this error I cannot see any reason why it hung in first place. . Since you are only using Fix Songs to fix data the processing is actually much simpler than the standard Fix Songs which encompasses matching from remote MusicBrainz/Discogs database.

But is E:\NaimMusic local or remote drive?, if it is remote and there was connection that maybe caused the issue, no network issue has been reported in logs but it is possible it has got hidden.

All I can really suggest at this point is use as local drive if possible and/or reboot pc and retry

Hi Paul,
thank you for your reply.
E: is a remote drive. I use it for testing new stuff like SongKong before I do any changes on my NAS, where the actual music is stored.
I also tried Sonkong with music from my local drive. Just tried it again, it faild again. Testing with “Preview Only” worked, without it, SongKong froze. I will send you the report.
Thaks again and have a nice day.

Thanks, okay it looks like a bug but I havent yet worked out why it is happening as there are no errors in the logs, I have raised

Since the last test is only against 13 songs could you please make them available to me, so then I can determine if the problem is related to something specific to these audio files or not.

Dear Paul,
thanks for your reply.
Of course I can make the songs availabe to you. Do you want the original files or the once where SongKong froze half way through the process?
How to makre them available?

Hi, original please, could you use Dropbox, Google Drive or something similar.

Hi, I have received your files and tested them on a Windows machine and have had zero problems.

So I suggest you:

  1. Reboot
  2. Start SongKong
  3. Run File:Empty Database
  4. Restart SongKong
  5. Run 13 file test

and report back.

Dear Paul,

thanks, I appreciate your support.

Meanwhile I followed your advice. Unfortunately same problem remains. I uninstalled and reinstalled SongKong. Didn’t help.

I will try SongKong with another laptop. Let you know the result later.



Can I check that you actually rebooted ?

Hi Paul,
reboot is same as restart, rigth? If so - yes, several times rebooted recent days.

Hi Paul,

just a short update.

I installed SongKong on two other laptops. At the first one SongKong froze same as on my laptop. At the second one it worked fine… I can’t figure out any big differences between these laptops.

However, at my QNAP SongKong is working fine.



Hi Ingo
So you have a usable solution then ?

Unfortunately as I cannot replicate the issue and there is no errors indicated in the logs, and no-one else has reported the issue it is difficult for me to progress this any further at the moment.

Hi Paul,
yes, I have a useable solution. It is working well.