SongKong and Jaikoz Music Tagger Community Forum

SongKong crashing and quitting unexpectedly on MacOS

Hi, I’m running SongKong on a 2018 Mac mini (latest version of Catalina). I uploaded my support files to you. My library has about 5000 tracks in it. I saved the problem report from my Mac, but can’t figure out how to upload it since you don’t accept txt files. Help solving this would be appreciated.

Hi, could you please email problem report to support@jthink.net

@hepshiba thankyou for sending the report so promptly

SongKong should never crash but the error looks very similar to https://github.com/igvteam/igv/issues/673 and points to a bug in the underlying Java/MacOS Catalina. We moved from Java 8 to Java 11 in 6.9 and I think that is part of the issue, I am just in the process of releasing SongKong 6.9.3 but then I will make this top priority

Has anyone else experienced a SongKong crash on MacOS ?

@hepshiba

Okay I think the problem is restricted to MacOS 10.15.3 when using an external monitor - https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8244818

Are you using 10.15.3 if so it should be fixed by updating MacOS to 10.15.4 - could you please try updating your Mac and letting me know if that resolves it.

Thanks for checking. I’m already updated to 10.15.4, so that can’t be it. I sent you another problem report but the crash was probably my fault this time because I accidentally set my disk to read-only. I’ll send you the next one, though. Also, whenever I open SongKong now I get a message that I should update to to 6.9.3. I’m on 6.9.2. But… when I follow the link and download the MacOSX version, it keeps reinstalling 6.9.2, so maybe that link isn’t quite right?

Okay, shame because they closed the Java issue because they thought it was fixed in 10.15.4
Okay, as a workaround can try selecting Remote Mode and control SongKong in a web-browser to see if that avoids the issue.

My mistake, the new MacOS version had not been copied over, please try now.

I downloaded the latest version, so that’s solved. But… I’ve got Preview unchecked in the Fix options. But when I open Remote, in the browser window, Preview is checked and greyed out and I can’t fix it. So I can’t test your suggestion. :frowning: I’m using Safari. Do you know what the problem is there?

No, that’s weird, can you try Firefox, and check your license details.

I don’t have Firefox. I do have Chrome and I’ll try with that. And my license details are fine. That’s why I can uncheck Preview in the program. Just not in the Remote setting in the browser.

Hi sorry I forgot that Web/Remote mode is only in Lite mode unless you have a Pro license - http://www.jthink.net/songkong/en/versioncompare.jsp

I have send you a free Pro license, please install and try then.

@hepshiba can you let me know if the workaround is working for you ?

Sorry, very heavy work days until tomorrow, then I can try it.

@hepshiba I have now seen the error occur for me as well on a Mac mini connected to a TV, I note that you are always using a MacMini and it is suprising no other user has reported this issue yet, so I wonder since the error refers to setView() if you also have a TV connected to your Mac mini and that is part of the set of circumstances that causes the issue ?

It took longer but the workaround I suggested failed because the main SongKong desktop window is still open. However you can start SongKong so it runs as pure server mode only accessible via web-browser and this should work for you (this is what we do when run on headless linux machines, i.e. servers with only a text screen).

You need to do the following:

  • In Finder open Utilties/Terminal app
  • In Terminal cd /Applications/SongKong.app/contents/bin
  • In Terminal ./songkongremote.sh

SongKong should now start in remote mode, and you can connect to it in a web-browser on your mac by entering the url localhost:4567

This bug is with Oracle (Java) or Apple (MacOS) so I have sent bug reports to both.

Hi, yes, I’ve got an LG TV attached. I’m still finishing up work, but will try your solution later today.