SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Rename cli task not working anymore

hi @paultaylor,

for whatever reason, I can’t get the rename cli to work anymore.

All the other tasks works flawlessly though.

it gets stuck here :

root@Murray:/mnt/cache/appdata/scripts# docker run --rm --name songkong_rename_test -v /mnt/cache/appdata/songkong:/songkong -v /mnt/user/MURRAY/Music:/music songkong/songkong -r "/music/Music_dump/01-1001" -p
debuglogfile is:/songkong/Logs/songkong_debug%u-%g.log
userlogfile is:/songkong/Logs/songkong_user%u-%g.log
songkong:remote dbinit
songkong:remote started

I tried to delete the database, same story.

I’m running this on a single album/folder and here are the debug logs :

root@Murray:/mnt/cache/appdata/songkong/Logs# tail -f songkong_debug0-0.log
24/06/2024 09.30.56:GMT:SongKong:setUserAgent:WARNING: start
24/06/2024 09.30.57:GMT:AbstractAcoustidQuery:performBasicSubmissionQuery:SEVERE: Posting to url:
24/06/2024 09.30.57:GMT:SongKong:setUserAgent:WARNING: end
24/06/2024 09.30.57:GMT:SongKong:writeSystemInfo:WARNING: SongKong 10.7 Gallipoli 1170 05/06/2024 using Java 14.0.2 14.0.2+12 64bit on Linux 6.1.79-Unraid amd64 initialized successfully
24/06/2024 09.30.57:GMT:SongKong:writeSystemInfo:WARNING: No of CPUs:32
24/06/2024 09.30.57:GMT:SongKong:writeSystemInfo:WARNING: Docker Mode Enabled
24/06/2024 09.30.57:GMT:SongKong:writeSystemInfo:WARNING: SongKong has been configured with minimum heap memory of 1,008 mb, maximum heap memory of 38,560 mb and maximum permanent memory of -32 mb
24/06/2024 09.30.57:GMT:SongKong:writeSystemInfo:WARNING: Total Computer Memory is 64,259 mb
24/06/2024 09.30.57:GMT:StartPage:createPage:SEVERE: RecreatingStartPage
24/06/2024 09.30.58:GMT:StartPage:setFolderInputField:SEVERE: -- GET:/music/Music_dump/01-1001/Joy Helder - Mermaid Fabrics (Slow Motion Edit) (2022) - [FLAC 24 bit]

As you can see, nothing happens. it’s, just, stuck.

Any idea of why this could happen ?

And yes, it just works when I run the rename task using the GUI. weird.

Its because you are using -r thinking it means rename when it actually means remote gui, you need to use -f instead.

damn, indeed :

rename or move files

thanks ! :slight_smile:

1 Like