SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Not parsing special characters correctly

I started getting this problem:

Is is just this album, can you give me the acoustid of one of the songs please.

AcoustID: fd1b01dc-2267-4764-af90-ac47b86ab7c6

It’s tagging everything like this now.

I noticed this behaviour after adding one of these:

To my recollection it didn’t happen before one of these.

I don’t see why adding those albums would have any effect on other albums, I thought may be some issue with Jaikoz 10.1.1 since it uses a newer version of java but it is working fine for me with artists that have accents.

You are using linux-headless version ?

I assume you have restarted Jaikoz and the problem persists ?

The problem started to occur in an older version. Version 10 i believe. I thought an update might do the trick, but it didn’t. I’m running Windows 10. Restarting didn’t do the trick, as well as uninstalling with keeping the settings and license files. I’m completely baffled as to what the problem could be. I don’t have this issue using foo_discogs.

I’m seeing no problem on Windows so it seems like a configuration issue.

Could you try stopping Jaikoz, renaming C:\Users\username\Jaikoz\settings.jai and restarting to see if the problems persists when using the defaults.

Still the same. I had already tried an older settings file with the same results, so yeah… I’m all out of options right now. Reinstalling windows or the likes isn’t really an option for me. I could perhaps test it in virtualbox later on.

So i loaded an unregistered new install of Jaikoz into VirtualBox and i still have the same issue.

Hang on, you didnt mention VirtualBox before, why are using VirtualBox I thought it was a native Windows machine ?

Yes i’m running Jaikoz on a native Windows machine. I’ve now tried running it in VirtualBox to see if the problem still occurs, which it sadly does. This is also a windows 10 environment.

Okay can you email the music files because if new install with default config and still not working seems must be related to the data.

Well i can, but i have to mention, and i did mention it’s doing it on all albums now.

Okay, I know you say that but I dont have the issue and you have installed a new version so I cant really think what else to try.

Loaded your files, some column showed the problem you had, some did not,

For this album I did Edit/Delete All Metadata and then ran Autocorrect it is working okay for me, can you try that ?

Yes, it has no problem with accents, apostrophes and the likes when it fetches data from MusicBrainz, but it does when it fetches the data from Discogs. Perhaps only accents and apostrophes. Haven’t seen any other problems so far.

Edit: these as well

ø ¿ ë

Or Russian, Chinese

Ah, okay it wasnt clear to me this was a Discogs specific issue.

Okay the invalid Discogs data is in the Albunack Discogs data, the Discogs data was updated a few days ago and used some new code for loading the database (discogs-xml2db) contributed by another coder. So I think there is a bug there but sorry its going to be a couple of days before I can track it done as I am away all day tomorrow.

Yes, in hindsight i probably had to be more clear/specific. Looking forward for a fix. May that be on discog’s end or your end.

I am rebuilding the database, to see where it is going wrong.

1 Like

I saw some things that may be related to what is discussed above. I started with audio files without metadata. After running Auto Correct, I got the result as in the picture below.

Notes on this result:

  • All artist names and all titles have been added in the Edit Panel, but some of them are not marked in purple.
  • Two artist names with diacritics do not look right in the Artist column of the Edit Panel, while they look right (in lowercase) in the Artist list of the Tag Browser.
  • Some titles with an apostrophe, get a backslash character in the title (but not all of such titles).

The problem was with the Discogs feed, they had a problem with their data. I have now rebuilt the database and now it is dealing with diacritcis/accents ectera okay. So Jaikoz should now work okay, but you’ll need to do Advanced:Empty Cache to clear out cached Discogs releases so Jaikoz gets the new ones