SongKong and Jaikoz Music Tagger Community Forum

Melco SongKong and the Mac

Hi
This is a little tangential but I wonder if anyone could shed light here. I have ripped a disc to the Melco and want to SongKong it as it does not appear under ‘composer’ - it is in the 'Import_CD folder as I can see it on the Melco in Folder ViewScreenshot 2020-02-08 18.34.57

when searching for it on my Mac either in Finder or in SongKong it is as though it is not there - see

I am completely baffled - If I try to re-rip it tells me there is a copy already present - I have tried ‘show hidden files’ but hat not worked either

Any help appreciated

Mark

It sounds as if the Mac does not have permissions to see this file, so if the user on the Mac doesnt have permissions then there is nothing you can do on the mac so that you can see it.

But why would this file have different permissions to the others ?

Why dont you put Songkong directly on the Melco now it can now be done for all models - http://www.jthink.net/songkongformelco/download.jsp

Thanks Paul - as a Pro user do I need another licence for the Melco as I am just about to go EX

thanks

M

You need a Melco license for full functionality and that applies whether you convert N1 to EX or just upgrade N1 to 3.92.

But you can install Songkong and use preview (to see if it can see the files) without any license.

Hi Paul
Yes - now I have installed SongKong on the Melco I can see the folder and get SongKong to run on it in preview mode

Is there an upgrade route from SongKong Pro to SongKong for Melco?

BW

M

I’m sorry there is no upgrade from Pro to Melco (only Standard to Pro)

Hi Paul

I have put SongKong on the Melco and it works splendidly. I have bought a second licence so I can now run both SongKong on the Melco and SongKong Pro on the Mac.

SongKong on the Melco can see this ‘missing folder’ (from the Mac) and so having SongKonged it It now appears correctly displayed in LinnKazoo. the only thin is that I will want to move the folder to a different position on the Melco File Tree - I can’t do this through the Mac as it can’t see it - is there any way of moving it or deleting it through SongKong on the Melco?

BW

M

Hi Paul. I am afraid I have had a bit of a meltdown as Minimserver seems to have stopped working after I did the first SongKong run - I am getting the following 2 notices

The minim server tag is showing red!

I know SongKong and Minimserve are quite different but as they need to work together I wonder if you could shed any light as to what I need to do as I really have no idea

Thanks

BW

M

Hi, you can use SongKong (for Melco) to move files as follows:

  • Load your folder and ensure that the folder path is split between Base Folder and Sub Folder correctly, so that Base Folder only contains the root, this is the part of the path we are going to replace, if it is incorrect you can use the left/right arrows to adjust

    e.g. we selected the /mnt/disk1/share/import_CD/Coldplay folder and it correctly split as baseFolder = /mnt/disk1/share/import_CD and SubFolder = Coldplay

  • Then on File Naming tab set the move folder for matched songs


    e.g we have set to /mnt/disk1/share/import because we want to move files from /mnt/disk1/share/import_CD to /mnt/disk1/share/import

  • Now start Fix Songs and we can see in the results that the files have now been moved as required.

  • Note Move Folder option only applies to songs successfully matched to a MusicBrainz or Discogs album, if you want unmatched files to move as well you just set the Move Unmatched Folder

HI, on a Melco N1 there is a special disk partition /mnt/system that is where SongKong, MinimServer and some system files are installed, in your case this appears to have been filled up. Now obviously installing SongKong has used up more space, however the space used by SongKong is fixed, it doesnt store logs, database or reports in this partition. So it seems that additional space is being used either by MinimServer or the Melco system, I will have to speak to Melco/MinimServer about this to find out the best way to reclaim some space.

the strange thing is Paul things seem to have changed again and now on Minimwatch

I just have this - everything useful seems to be greyed out

M

Well it isnt strange really, there is no space left to allow MInimServer to work properly

Hi, I have created a new release with some debugging to try and find out what is using the extra space, because this is a special test release you have to follow the instructions at How do you install Melco SongKong Test Version to install it.

This will then allow you to install SongKong 6.8.2 (this is different to SongKong 6.8.1 released earlier today), and then if after installation you could run Create Support FIles I should then be able to see what is using up the disk space.

Hi Paul.

I may have made things worse as David suggested rolling back to Melco 3.91 and do a restore after erasing the Minimserver folders and the SK from the backup. I have tried to do that but some of the files in the Minimserver folder would not delete - I am therefore trying to restore a back up now but worry I might be in a bit of a hole if I have remaining fragments of MS - we are about 20% in at the moment

I’m sure we will be able to sort it out, but it would be very useful if you could upgrade to 3.92 again and install this latest version of SongKong and run Create Support Files before trying to reinstall MinimSever (so you have space) so we can determine what is using up all the disk space, it may well be a Melco file unrelated to either SongKong or MinimServer.