SongKong and Jaikoz Music Tagger Community Forum

Jaikoz - Java Question on MacOS

Hi There,

Am running on Mojave 10.14.6 and installed the latest jre-8u231 from Oracle.

When I attempt to start Jaikoz Pro, I get ….

I assume that something is not right with Java, but everything does seem to have installed correctly - I have the Java control panel in System preferences for example.

Please advise.

Jaikoz actually comes with its own copy of Java as part of the installation so there is no need to install Java yourself. I just wonder if somehow your separate install of Java has confused things, but never had this error reported before.

Did Jaikoz used to work, if so when did it fail ?

Could you run Create Support Files from the Advanced menu, then please email support@jthink.net the zip file that is created.

Hi Paul,

I have completely removed Java and Jaikoz from my system and then a clean download and install of Jaikoz (with no separate Java installation). I get the same error. I can’t send you any error logs, because Jaikoz fails to load.

Jaikoz has never worked. This is my first attempt at using it. The first time I attempted to use it was without the separate Java install; I dod the sepearet Java install to try and solve the problem.

I am on an iMac Pro - could it be anything to do with the enhanced security?

As a follow up, the Jaikoz directory does exist in Preferences. Contents as follows:

Hope this helps.

Okay, can you go to Logs/Jaikoz folder and send anything inside there.

As requested …

20/01/2020 15.41.28:com.jthink.jaikoz.MainWindow:setupOnFirstTime:SEVERE: osLanguage5:null
20/01/2020 15.41.28:com.jthink.jaikoz.MainWindow:setupOnFirstTime:SEVERE: osLanguage6:en
20/01/2020 15.41.28:com.jthink.jaikoz.MainWindow:setLocale:SEVERE: Setting Locale:en
20/01/2020 15.41.29:com.jthink.acoustid.query.AbstractAcoustidQuery:performBasicSubmissionQuery:SEVERE: Posting to url:http://api.acoustid.org/v2//user/create_anonymous?format=xml&client=8XaBELgH
20/01/2020 15.41.31:com.jthink.jaikoz.db.Db:printSQLException:SEVERE: Err:Connections could not be acquired from the underlying database!:ErrCode:0:State:null
20/01/2020 15.41.31:com.jthink.jaikoz.db.Db:printSQLException:SEVERE: Err:No suitable driver found for jdbc:derby:/Users/JDED/Library/Preferences/Jaikoz/jaikozdb;create=true:ErrCode:0:State:08001
20/01/2020 15.41.31:com.jthink.jaikoz.MainWindow:setupWindow:SEVERE: Unable to create database /Users/JDED/Library/Preferences/Jaikoz/jaikozdb because No suitable driver found for jdbc:derby:/Users/JDED/Library/Preferences/Jaikoz/jaikozdb;create=true
java.lang.RuntimeException: Unable to create database /Users/JDED/Library/Preferences/Jaikoz/jaikozdb because No suitable driver found for jdbc:derby:/Users/JDED/Library/Preferences/Jaikoz/jaikozdb;create=true
at com.jthink.jaikoz.db.Db.createNewDatabase(Db.java:324)
at com.jthink.jaikoz.db.Db.(Db.java:95)
at com.jthink.jaikoz.db.Db.getInstance(Db.java:115)
at com.jthink.jaikoz.MainWindow.setupFirstTimeOrUpgrade(MainWindow.java:458)
at com.jthink.jaikoz.MainWindow.setupWindow(MainWindow.java:287)
at com.jthink.jaikoz.Jaikoz.main(Jaikoz.java:137)
Caused by: java.sql.SQLException: No suitable driver found for jdbc:derby:/Users/JDED/Library/Preferences/Jaikoz/jaikozdb;create=true
at java.sql.DriverManager.getConnection(DriverManager.java:689)
at java.sql.DriverManager.getConnection(DriverManager.java:208)
at com.jthink.jaikoz.db.Db.createNewDatabase(Db.java:260)
… 5 more

And you are running it by simply double clicking on Jaikoz icon in /Applications folder ?

Yes - the first time I had to “allow” it to run - the usual Apple security dialog. After that - just double-click and get the error message (every time).

Hmm, okay just try this one thing.

Delete the Preferences:Jaikoz folder and then try to start Jaikoz.

Did that - identical content as before - just different timestamps.

I am going to have to think about it, cannot understand why you have got this error and nobody else has.

OK Paul. Just to fill you in on system specs.

I assume that log extract was jaikozdebug0-0.log , was that the only log file ?

Yes - just that single file in the directory. Seems to always have the same content - just different timestamps.

This is want I get o n first run. Nothing seems out of the ordinary?

Does this look right (from the command line)?

OK - I have run out of ideas. I went into Terminal and completely removed that old JRE. I completely removed Jaikoz (app, preferences, logs) and restarted. I then did a clean install. Still the same error message. I have done a successful installation on a MacMiniPro and everything works as it should, so I know the installer is good. There is something about this iMac Pro that is blocking things!

java -version now just pops up a dialogue box to download java (which I cancel out of).

Went through the unified log …

11:05:41.805481 int launch(char *, int, char **) Launchpath: /Applications/Jaikoz.app/Contents/PlugIns/jdk1.8.0_192.jdk/Contents/Home/jre/lib/jli/libjli.dylib
11:05:41.810271 register name: com.apple.xctest.FakeForceTouchDevice object: com.jthink.jaikoz token: f4246 pid: 902
11:05:41.822488 int launch(char *, int, char **) Launchpath: /Applications/Jaikoz.app/Contents/PlugIns/jdk1.8.0_192.jdk/Contents/Home/jre/lib/jli/libjli.dylib
11:05:41.982566 CHECKIN:0x0-0x73073 902 com.jthink.jaikoz
11:05:41.983078 -[ApplicationManager checkInAppContext:refCon:eventData:] | checked in app : Jaikoz
11:05:41.987982 -[PersistentAppsSupport applicationReady:] | App: Jaikoz, ready, updating active tracking timer
11:05:42.015773 -[TCCDAccessIdentity staticCode]: static code for: identifier com.jthink.jaikoz, type: 0: 0x7f8470f1adf0 at /Applications/Jaikoz.app
11:05:43.293117 BundleID ‘com.apple.finder’ for Path /Applications/Jaikoz.app
11:05:46.192103 register name: com.apple.nsquiet_safe_quit_give_reason object: com.jthink.jaikoz token: f42ca pid: 902
11:05:46.990177 -[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] | checkAgainstApp is : Jaikoz
11:05:46.990179 -[PersistentAppsSupport appShouldBeRelaunched:] | entered. checking app: Jaikoz
11:05:46.990181 -[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] | Adding to relaunchArray: Jaikoz
11:05:46.990396 -[PersistentAppsSupport saveLogoutPersistentState:finalSnapshot:] | Contents:(
{
BackgroundState = 2;
BundleID = “com.apple.finder”;
Hide = 0;
Path = “/System/Library/CoreServices/Finder.app”;
},
{
BackgroundState = 2;
BundleID = “com.apple.terminal”;
Hide = 0;
Path = “/Applications/Utilities/Terminal.app”;
},
{
BackgroundState = 0;
BundleID = “com.jthink.jaikoz”;
Hide = 0;
Path = “/Applications/Jaikoz.app”;
}
)

Jaikoz installs its own version of Java (1.8.0_192), but this runs in parallel with any other installs, okay you can run direct from the command line as follows

  • Open Terminal
  • cd /Applications/Jaikoz.app/Contents/Java
  • sh ./jaikoz.sh

Lets see what that gives, I get this

No java runtime present, requesting install.

the contents of that directory are: