SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Installing SongKong on a MELCO/N1

Bonjour Paul,

I’m trying to install SongKong In My N1. And this, according to the published installation method,(USB Key inserted Within 'Expansion" USB port, and waiting 5 minutes) after restart the N1.

I can see the “Sonkong/Logs” (and not “SonKong/log”) new created repertory, but it remains empty (no log anymore).

Does anyone having a Melco experienced that?

Exactly the same here - the SongKong folder is visible in the share, but contains only an empty Logs folder?

Installation instructions state “ensuring shared N1 drive is mounted on your computer” - is that the same as mapping the N1 network ‘share’ so that it appears as a drive under ‘This PC’? eg I have:

share (\\DOMS-MELCO) (Z:)

Thanks for any help,


Have you tried rebooting your Melco, and waiting a couple of minutes ?
Have you installed the latest firmware, If you have I just wonder if that is causing an issue ?
Could you email the contents of your melco SongKong folder ?
The best way to reoslve this is perhaps for me to use Teamviewer to remote login to your machine, if you would like me to do this please install teanviwer and then email details of a suitable time to do this, (please be aware I am based in UK)

Yes Paul, I?ve had a couple of goes at rebooting, and even reinstalling a fresh download.

The Melco is running the latest firmware.

The SongKong folder contains a single empty folder titled Logs, and I think there was a separate .txt or similar file outside the folder that recorded an expansion drive had been detected.

I?m away with work for a couple of weeks now, but very happy to provide remote access once I?m back at my laptop and Melco.

Thank you for getting back to us,


Hi Paul,

Thanks for your response,

My sit rap is similar to Dom,

1- My melco operates under 3.91 Version (latest release from Melco).

2 - I tried many times to restart/reload with the USB key inserted into “Expansion” USB Port, but the problem remains the same. even after 5 or 10 minutes waiting.

3 - The “SonKong” folder contains only “Logs” repertory, which appears empty. See Attached files (.zip).

4 - Ok for your proposal with the remote access.
4.1 - I operate in Apple World (Latest OSX basic software) , I guess the remote tool is also available with my Mac mini;
4.2 - I 'll be free only This Saturday Afternoon. I’m living in France ; so English Time + 1 hour :-).

Sorry, I havent forgotten about this I will be doing some testing on my Melco tomorrow

Hi, I reset my Melco N1 and installed SongKong 6.1 and managed to replicate the error with only the Logs folder being created, so my suspicion is that something in Melco firmware 3.91 has broken something, but it could possibly be an issue with SongKong 6.1 so I will continue to do further testing and get back to you once problem is identified and then again when we have a solution.

Thank you for the update Paul, and very pleased to hear it wasn’t simply ‘user error!’

Found the problem, I had inadvertently added Dos line breaks to the Melco startup file when editing and this meant it would not run on the (linux based) Melco machine.

Please download again, and it should install properly this time.

Hi Paul,


I reinstalled Songkong (6.1) within my Melco, inserted my License Keys, and I am currently tagging my first Musical File “In Situ” within The N1:-).

Merci Beaucoup Paul!

Excellent news, I?ll give it a go this weekend.


That looks to have worked Paul, thank you. Just following your previous advice about embedding Naim .wav metadata.

I installed trial version of SongKong on the Melco N1A and get nothing. MinimServer is installed also. I am using an Amazon Fire tablet as a remote with Bubble UpNp. MinimServer starts up Ok, and when I look at the network on my desktop computer in the share folder, I can see that SongKong is installed. I have rebooted all components many times with the same results. No SongKong.

Hi Rekab

Its not working because you go to http://melcoipaddress:4567 and dont see the SongKong page ?

From your desktop computer can you please send email the contents of the SongKong\Log folder