SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

How stop existing user-defined fields getting moved/merged into Comments?

Many of my existing MP3 files have been part-tagged - in each case, an ID3v2.3 tag with a certain few frames populated. Some of these frames are TXXX, essentially acting as my own user-defined fields. Some apps permit the mapping of fields (as they appear in the app) to these frames (distinguished by what are essentially text-frame-type identifiers, when used like this). One such me-defined frame is Association, e.g. for radio stations, eras, people or incidents I associate some music with. Another is Story, where I paste text for things like what gave rise to a composition or a release (e.g. found in Wikipedia articles about bands and songs).

When I open such files in Jaikos, my user-defined fields (such as Association and Story) are not recognised - not available as columns in either of the tables (Edit, ID3 Edit). Instead, the contents of all of my user-defined fields appear merged into the single field/column Comments. I understand (now) that this is intentional behaviour, as a work-around in lieu of “proper” handling of user-defined fields.

Incidentally, I see that Jaikos itself has its own “user-defined-fields” where e.g. Mood, a frame only present (as TMOO) in the ID3v2.4 tag specification, can nevertheless be represented (as TXXX:MOOD) in ID3v2.3 tags (which is what I use, for compatibility with apps I wish to use). However, being Jaikos-created, such frames benefit from special Kaikos treatment, appearing explicitly as their own field/column in the Jaikos tables.

Of course I’d like this for user-defined fields! And have voted as such.

But my question is - is there currently any way to prevent user-defined fields from being merged into the Comments field ? Because (after saving to file) it essentially disrupts my existing tags:

  • The user-defined frames (in the ID3v2.3 tag) lose their content - they are left empty.
  • The Comments get “polluted” with that content.
    It would be better for my situation if the user- (but not Jaikos- ! ) -defined frames were simply ignored.
    How do I get that to happen?

Any advice would be appreciated.

For ID3 format if you have created custom fields in another application and they are mapped to a TXXX field (User Defined Text Information) field then they should at least be visible under the User Defined Text Info field on the ID3 tab, in fact most fields map to this field as this is what is used for any plain text field that does not have its own special field like artist, title ectera.

For example here is a couple of screenshots showing that most fields maps to the TXXX frame

If Jaikoz is showing them under the Comment field then I expect your application has actually mapped your custom fields to a COMM frame not a TXXX frame, since it is allowable to have multiple Comment frames as long as they have different short description

So if after checking you think TXXX frames are being shown as COMM frames in Jaikoz you should email me an example.

1 Like

Yes indeed - it worked as you described - so there is/was no problem after all.

Thanks to your reply and a bit of simple testing (as below) I am now a little bit more “in tune” with how this works. I like that my user-defined fields appeared in the same way as multi-value fields in the User Defined Text Info table-column. Click on the little number and a dialog appears, presenting (editably) each field in its own row.

I don’t know what went wrong previously - maybe a “not sufficiently awake” error on my part. Or maybe some inter-app issue that happened to be fixed by the recent update?

Details of the Test:

Just now, in a separate app (Mp3Tag-macOS), I created a fresh ID3v2.3 tag and populated (hence added) a couple (2) of my “user defined fields”. A hex editor revealed that, as expected, they had become stored in the file as TXXX frames, each named after its corresponding user-defined field).

Then, when I opened that file in Jaikoz, those fields appeared in the User Defined Text Info column of the ID3 Edit table, in the same manner as “multiple values”. In my case, the little number “2” appeared to the left of the relevant cell. When I double-clicked that number, to my delight, a dialog window (Update Description and Value) appeared, enabling me to see, select and edit each of these 2 items individually in its own row. Brilliant!

I then edited (changed) the string-values in these two fields. On (saving then) loading the file into other apps, the two new values appeared as expected (e.g. when viewed as separate fields in one of those apps).

So no problem, and I learnt something.

1 Like

Great, just to note only files using ID3 format can see these custom frames using Jaikoz it is not an option for other formats such as Flac. So we will still be adding support for configuring custom columns that would be seen on the main edit tab.