SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Help! Newbie can't get SongKong to work using Melco

Hello - I can’t get anything to work within SongKong and my Melco automatically switches off the SongKong service if I try any of the features within SongKong i.e. Status Report etc.

I have just purchased a pre-loved Melco N1Z SSD that has been updated to EX spec. I have uploaded SongKong to the Melco and it shows version 7.0.
I then tried the IP address adding 4567 on the end to get to SongKong on my Laptop. After numerous attempts I finally got there and it shows the SongKong page. I then realised I needed to Map the Melco drive, so I assigned it to ‘Z’ following the instructions but i still can’t see any of my music or use any of the features within SongKong.

With the Status Report it shows the 4 blue bars and eventually shows 0/6357 songs but then the Melco disconnects from SongKong and if I refresh, it can’t connect to the IP address.

I have tried many times but I can’t work it out. Can anyone please help, and let me know if showing any relevant screenshots would help, as I can follow basic instructions but I’m not that technically minded.

Many thanks

Hi Russ,
Mapping to the Z drive is only necessary if you are actually running SongKong from your PC, there are two ways to use SongKong with your Melco:

  1. Connect to SongKong on your melco via your PC web-browser, because SongKong running on Melco it can see the files on the melco.
  2. Install SongKong on your PC and run on your PC, it can then fix songs on your PC and files on your Melco if you map Melco drive to a shared drive on your PC (e.g Z:)

Running SongKong on your Melco avoids the effect of the network when reading and writing music files, and because access is via a web browser you only need a phone or tablet to use it, a PC is not required.

But if you are using a PC although you introduce the network overhead when reading and writing files the processing power and memory capacity of your PC is likely to be significantly greater than your Melco so overall processing time is likely to be quicker. A full Melco license can be used on both a Melco and a PC.

But going back to running SongKong on a Melco can you please check if SongKong is still running as follows:

  1. Select 4>Settings from the Melco OLED
  2. Select 2>Music Database from Settings menu
  3. Select 2>SongKong from Music Database menu
  4. Select 1>SongKong Service from SongKong menu

Does SongKong show On or Off?

Hi Paul, thanks for your assistance. SongKong currently shows On as I turned it back on after my last attempt with SK turned it off again.

I think solution 1 of your description is the way I want it to work so using the Melco and only browsing using my PC. Should I disconnect the Z drive from the Melco?

Okay so can you open start page in webbrowser and send screenshot, then from menu bar at the top run Create Support Files

You can disconnect Z: drive if you like, it makes no difference to SongKong

Hi Paul, I hope you can see the screenshot. I’ve run the Create Support Files. Does it go to you?

Yes, okay SongKong is crashing with

java.lang.OutOfMemoryError: Java heap space

error every time you try and start it, before you actually do anything in particular, this has happened about ten times although it doesnt look like it happened this time or yo would not be able to run Create Support Files

So it seems the problem is either your Melcos actual physical memory or something else running at the same time utilising too much memory, are you using Twonky or MinimServer and do you have a very large music library?

Hi Paul, I’m running Twonky and the Music Library is only 16% full with 6256 songs on the Melco’s 2Tb SSD.

Is SongKong still running or has it now crashed, either way can you try switching off Twonky temporarily and then try SongKong (restarting if necessary).

I can still go back to the start screen on SK if that is what you mean? It is also still on on the Melco. Shall I switch off Twonky on the Melco and then do what with SK?

Can you access the files on SongKong, I cannot see obvious music folders on that screenshot, what folder do they reside in ?
Actually it would be helpful to me if you remount Z: drive on your PC and firstly post screenshot before do anything else so I better understand your music folder structure in case that is part of problem.

Is that the correct one?

No, I don’t want to see the Logs folder I want to see the music folder, when you connect to an EX from Windows it shows it as Internal

Is that better Paul?

Hi, yes okay I think I know the issue
SongKong works folder by folder, so usually it can work on any size of library because it works on each folder independently, but I see here that all your files are within a single folder and because the Melco is fairly memory constrained it cannot handle this.

If you can use your PC to break into a number of subfolders then I think it will be okay.

Sorry Paul, I don’t understand. The Melco plays song etc fine, no problems. Its just using SK I seem to have issues.

To get all my music onto the Melco, I did a USB copy of my Synology NAS onto a USB HDD and imported that directly into my Melco.

What do you suggest I do with the files, and how do I go about it? Could the fact I only mapped the ‘Logs’ file instead of the ‘Internal’ file be the problem or is that a red herring?

I’ve just tried running the Status Report again but no luck and the Melco has disconnected from the SK Service again.

That is a red herring.

Users normally stores their music files in folders so there is a folder per album, and each folder for an album is within an artist folder, like this:

But you have all your files in a single folder, are they like this on your computer where you made the copy to the USB disk?

Now for playing music the folder structure doesnt matter as long as you have the basic artist and album metadata in the files. But when identifying the songs we are trying to match not just songs but also albums, so we group files logically to help with this, and the first step is grouping by folder, but in your case we have only one folder containing all the files. Now SongKong can deal with random folders containing many songs from any albums, but not this many songs and especially not on a Melco.

So I am asking you to use Windows Explorer to try and split it up a bit, as a test you could just put the Abba songs in its own folder and then run SongKong on the Abba folder and it should work fine.

Thanks Paul.
I’ve just opened up the actual Melco Folder ie.‘N-2EB5:Music Library’ and all the albums are in folders. Please see screenshot below. So now I’m really confused! I copied all my music from the NAS to the USB HDD and then import this directly to the Melco. I had no idea how the NAS stored the Music or maybe there was an option when I copied from the NAS to the USB HDD to remove all the folders? I think I’ve had enough for today!

I think these are just virtual folders based on album metadata
Does the Z:\drive show any folders within the USB_Copy… subfolder or not.

No, no folders within the Z:\drive. Would I need to create these folders for each artist/album within the Z Drive, as I thought the Z drive is not required. Can you see why I’m confused?

Your Z: drive is simply making your Melco filesystem available to your PC, Z: drive is not required for SongKong itself to run, but is required for you to modify folder structure before you use SongKong since SongKong has a problem with your existing structure and you cant login to your Melco like a computer.

You certainly need to create some folders, artist/album would be best, but even if you just split by artist that would be good enough. As I said earlier would be good if you just create an Abba folder and then just run SongKong on the Abba folder to confirm it will work.