SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Getting Fatal Errors on Save

Hi Paul,

I am processing one subfolder at a time within my /Music folder. Some with relatively few tracks, some with 10k-20k tracks. I’m getting an error on some of these, not all, in response to which SK stops. It says, for example:

“5,845 songs checked against MusicBrainz and Discogs before task cancelled by SongKong because of unreported error”. When I go to the error page of results, I see: “Problem with Save:null”.

How can I figure out what the problem is?


Run Create Support Files - that will send me the log files and I can see where the problem is occurring.

Sent, thanks.

BTW, I’m trying to process for Roon deleting and repopulating Genres and processing artwork. Nothing else (hopefully).

Hi. okay I can see there is a problem occurring on Save, but because of an additional error in the error handling code I cannot see what is causing it but it is likely to be a bug introduced with SongKong 7.2 Cassadaga. So I have already fixed the error in the handling code so it will now show the error but I need to get this new version to you, and for you to retry so I can see the actual error.

Am I right in thinking you are using Docker version ?

Then once I have found the error I can create another release with the fix.

Also please note the errors only cause problems for a few files, the other files will continue to save correctly, the saved bar on the report correctly reports actual saves.

Yes, Docker version on a QNAP, thanks.

Okay, so I have already uploaded a new of SongKong 7.2 for Docker, this will not fix the issue but it will give me the additional information required to fix the issue, please install as follows:

  • Stop existing SongKong container
  • Delete SongKong image
  • Redownload SongKong image
  • Start container
  • Run Fix Songs to generate error
  • Run Create Support Files to send me logs and reports

Although it has same version number, you can confirm you have new version by checking the About menu item. The new version will say Build Date 09/03/2021 whereas the original version will say Build Date 08/03/2021

If you haven’t done this yet the new version will now say Build Date 10/03/2021 rather than Build Date 09/03/2021 because I have added some addtional debugging for another issue.

Thanks for the logs, I now have the full stack trace so should be able to resolve the issue, but its end of the working day here, I will have a look tomorrow though.

Ok. But do you want me to redo with 10/03/2021 version?

Hi, no the 10/03/2021 version change just added debugging for another issue.

I’m sorry but having looked at the logs I can see where the error is occurring but it didn’t tell me what file was having the problem and hence I don’t know why particular files are having a problem. So I have added further debugging and built a new version with Build Date 11/03/2021. So could I ask you install this new version and repeat the procedure please.

I may be ok now, thanks. I’ll work with it a bit more and need to bite the bullet and read through the help pdf more. But I got that same folder to process and found two albums that generated errors that I could fix. No unidentified kind of errors now. I’ll report back if there is more difficulty when I process other folders.

Do you need me to try anything for figuring things on your end?

Hi, so you ran the latest version and it showed you the file causing the error ?

Could you please run Create Support Files again so I can see the cause of the problem so then I can deal with the the issue for other customers.

Sure, coming right up.

BTW, is there a way to save the settings? They seem to reset whenever I install a new version.

Yes, you are missing configuring the /songkong folder please see On Docker why do I lose my license when I update SongKong?

Thanks, okay so I can see the errors were all within the

/music/Jazz Vocal/Holiday, Billie/2008 - The right to sing the blues/


But cant see anything special about it, don you ?

Thank you! I did miss that.

What I did was use MP3Tag to look and found inconsistencies. I made the same fields between tracks more consistent and the error went away.

However, since I was setting the processing settings each time I re-installed, I don’t know if I changed anything significant between runs.

Paul, I reconfigured the container in order to retain settings. I needed to set everything again for this install though. I ran against the same folder and got an automatic cancellation due to an unreported error. This time, when I went to the warnings/errors report, it showed zero. So again, I don’t know what the error is, so we are evidently not out of the woods yet! …Pete

Yes because you are moving the configuration from where it was previously was so first time it wont find a configuration, but shouldn’t be a problem from now on.

There is an unreported error because if you at the summary report its shows that 6126 files were loaded

but only 6125 completed processing

This difference of just one song indicates to SongKong that one song did not complete processing for some reason (that we don’t know) and therefore it reports the error. It is only one song so I think you can just ignore this and put it down to a glitch.

I am glad you resolved your problem with the Billie Holiday album, however the extra debugging helped us to identify the album but I’m still no clearer on the cause of the problem, can you remember if you renamed the songs in Mp3Tag or just changed the metadata ?