SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Genre Display as Numbers

SongKong tag some album Genre display as Number in JRiver but Jaikoz doesn’t have this issue.

This is the Result Tag By SongKong

After Retag using Jaikoz

After tagging with SongKong if you just load the files in Jaikoz does it show number or text for genre ?
What ID3 version are the files ID3v23 or ID3v24 (Version column in Jaikoz) ?

After tagging with SongKong if you just load the files in Jaikoz does it show number or text for genre ? Text
What ID3 version are the files ID3v23 or ID3v24 ( Version column in Jaikoz) ? ID3V23

So that shows that although it may be writing numbers that SongKong seems to be writing them in the correct way so they can be mapped to right value.

I wonder if there is an issue with JRiver ?

Try rerunning Fix Songs on the files in SongKong after modifying Mp3 Metatag Version to V24 to see if JRiver is okay with that.

If not please email support@jthink.net one such audio file.

Ive try by change the MP3 Metatag Version to v.24 as request.
Ive also try to force Rematch using SongKong alone but it didnt change the Genre which it display as numbers.


Ive send a support Report on this.

Please email support@jthink.net one of the offending music files so I can check it.

Hi, okay I have found the issue, on the Save tab there should be an advanced option called Save songs so they work best with iTunes

but there isn’t because of a bug

Enabling this option does two things

  1. Save genres as text
  2. Doesn’t set Album Artist to Various Artist because iTunes provide own internationlized value in such cases.

Workaround is to start Remote Mode once, because the web ui does have the option and enable the option and start Fix Songs, then it will be saved to profile and no longer need to use remote mode.

I have fixed the bug and will add to new release, but it will be a few weeks before released.