SongKong and Jaikoz Music Tagger Community Forum

Flac files not being recognised as such

Hi,

Firstly let me say how much I value your programs. I’ve tried a few (Bliss, perfect tunes, etc.) on my path to an organised music collection and have concluded the combination of your two programs is the best in terms of being able to fix things quickly and easily and being able to make whole collection changes. Thank you.

I just downloaded some new music from Qobuz using their App and the file names are not exactly as I would like (’-’ rather than ’ ') so I fired up SongKong v6.1 and get some very odd results (see attach 1 for message dialog). The folders are reports as containing no songs SonngKong can read!

My first assumption was I’m messed up, and the files were not FLAC files, but the dbpoweramp file properties extension shows the following (also in attach 2) show file as flac, and it plays OK.

Artist Vampire Weekend
Title We Belong Together
Album Father of the Bride
Track 15/18
Disc 1/1
Genre Pop Rock
Year 2019
Rating
Composer
Size 73.45 MB (30% Compressed)
Original Size 104.77 MB
Length 3 minutes 10 seconds
Channels 2 (stereo)
Sample Rate 96 KHz;
Sample Size 24 bit
Bit Rate 4,608 kbps (DVD)
Encoder
Encoder Settings
Audio Quality Perfect (Lossless)
Contains Album Art, CRC, ID Tag [Vorbis Comments]
Channel Mapping
File 1_15_Vampire-Weekend_We-Belong-Together_7
Type FLAC Audio [.flac]

I then tried loading Jaikoz and matching each album to one MusicBrainz album which worked.

Any idea what I’m missing?

I know I could use Jaikoz, but I have Songkong setup for quickly tidying the album name and song names of recently ripped or purchased music and tend to use Jaikoz for significant batch changes.

Many thanks,
Dale

Hmm tried to submit this a few times and get an error message. Will try without attachments

Hi Dale

Very surprised this problem has not come up before, but basically SongKong didn’t like your filename, it had a problem with the underscore near the start

https://jthink.atlassian.net/browse/SONGKONG-1750

Replacing _ with - will work, and I have already fixed this bug in SongKong ready for next release.