SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Fix Songs not processing

I am running Songkong on Mac Airbook, M1. Had many successful hours of using Songkong to properly tag albums ripped by Naim N-serve but like a stubborn two year old, its just refusing to do any more!

I am used to seeing a progress bar and receiving the report after a few minutes of processing, with a neatly tagged album the result. Now, I start the process and it flashes straight back to the main menu, as if its completed the job in a second without producing a report.

I have tried emptying the database, reports folder, log etc. Uninstalling and re-installing, but nada. I must be missing something obvious so would be grateful for suggestions…thanks.

Looking at your logs I think you have two copies of SongKong running and that is messing things up, it maybe that one is no longer visible but still there. Best solution is to reboot to ensure no longer running then start SongKong and retry.

Thanks Paul. Tried that, no different. Also interestingly I can’t now manually edit a selected album. All help appreciated.

Ok so you restarted computer?

Please resend support files again.

Hi Paul - yes I have restarted macbook several times.

Also noticed in my previous version (10.4.1) I can manually edit, but the fix doesn’t seem to do anything whereas in the latest version neither the manual edit nor the fix work.

I’ve also sent the support files.

Looking at logs you have now downgraded from Gallopi to Amnesiac but you cannot do that because all your config files have been updated to Gallopi and there is no code to downgrade.

01/07/2024 21.06.16:BST:SongKong:firstTimeUpdate:SEVERE: Updating from 1170 to 1163

So you should reinstall Gallopi, and now you don’t have two copies of SongKong running at same time should now be okay.

Alternatively if you want to stick with Amnesiac you would need to manually delete the Library:Preferences:SongKong folder beforehand so the install works like a new install.

Hi Paul - I have deleted Amnesiac and reinstalled Gallopi. Still no joy. I am now unable to manually edit nor autofix, so no further forward.

I have sent the support files.

All help appreciated.

Have you redone Empty Database?

Okay looking at logs and there are various initialization errors, it seems your installation is all messed up, you need to do the following:

  • Delete /Applications/
  • Delete the Library:Preferences:SongKong folder
  • Reinstall SongKong
  • Reinstall License

hopefully that will fix things

Thanks Paul. It took me a while to find the right library folder but got there in the end and it’s working again!

Much relieved and very grateful for your support.

Many thanks

1 Like