SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Deleting a folder that SongKong can see - but computer can't

Hi
I have imported a set of CDs into the Melco EX and put them through SongKong on the Melco. I was wanting to ‘tidy’ up using JaikOz and 6 of the CDs could be seen - but not the 7th (It is there as it appears in LinnKazoo and in SongKong on the Melco) just can’t see it on My MAC or with SongKong on the Mac (or of course JaikOz)

I have reimported it - probably making it worse as there are now 2 copies showing the same behaviour. - Is there a way of using the SongKong on the Melco that can see them to delete them - or is there a smarter way of doing this

Many thanks

M

There is currently no Delete facility but what you can do is use Manual Edit to load the files, then there is probably some special character in the filename preventing them from being displayed on Mac. You can rename the Filename column on the Filename tab, Save changes and this should then allow it to be visible on your Mac and then deleted.

Thanks Paul
I am not sure how to use Manual Edit - is that under the Tasks - Edit Song Metadata?

All I can find there is the pathway - so we have "/mnt/disk1/share/1 Music in WAV or Final Format/3 - Music Auto SongKonged - ready to Jaikoz and file/RCA-Living Stereo/Vernon Handley/Vaughan Williams Symphonies #6 & 9 Fantasia On Greensleeves /01 Vaughan Williams Symphony #6 In E Minor - 1. Allegro.wav

the only thing that looks odd (if I am in the right place) is the little . which actually has a x in it - but I can’t see anything else - sorry if being a bit dense!!

Thanks for your help
M

Sorry, yes its the same thing.

So yes you can edit pathway (see Filename column in screenshot)

The  definetly looks suspect so remove that from the filename and select Save and see if that file can now be seen on your Mac.

Thank Paul

I have removed the  and saved the files - but still nothing is showing on the Mac or JaikOz

Where to next do you think?

M

Can you go back into Edit Song Metadata, go to the Filename tab and show me a screenshot so I can see the file paths of the problem file.

Also a screenshot from Mac Finder showing what it can see would be useful

Thanks Paul

I have added the 2 screenshots you asked for and also one of the relevant part in SongKong

In the one of the file path - the overall path can be seen by combing what you can see in track one and track 2

Thanks for your help

M

Try removing the # characters

hi Paul

I have removed the # from each of the files - but it is still not visible on the Mac

Look forward to your thoughts moving forward

BW

M

Hi Paul.
I have got back to check - and although the # and the  have now gone - when I run a report they still seem to be present - see here -

but not here

Have to say I am really confused - hope you can shed some more light

BW

M

Gone from where ?

Could it be that there are 10 songs in that album, you have renamed one so it is now visible within the Vernon Handley folder, but the other nine still reside in the folder starting with Vernon Handley but with the extra character.

Please try renaming all files to correct the problem Vernon Handley folder to see if that resolves it.

Hi Paul

I went in again last night there are 9 tracks which I can see (and I would guess a cover photo which I can’t see) each of the 9 tracks had an # so I removed 18# in total - but can still not see anything!!

I will go and check again but I think we have already don’t this stage - unless there is something linked to the image or if there is something else we can’t see!!

Look forward to hearing from mm you

BW

M

I dont think its the # its the  char that I can still see in your Edit Metadata report, it is the  after Vernon Handley that should not be there.

The difficulty now Paul is that the , and the # have gone from the file edit screen - as you can see here:-

But when you save and run the report they still seem to be there!! - as you can see here:-

I don’t understand enough about how SK works to know what to do next

BW

M

Hmmm, okay well I dont’ understand the cause of this issue either but what I would suggest it to try and totally remove the /Verson Handley/ part of the subfolder and see if that resolves it. Also could run Create Support Files - maybe that will tell me something.

Hi Paul

It has got rid of the Vernon Handley as you can see here -

But it has not revealed the subfolder in Finder

It is still there in Linn Kazoo as you can see here : -

I have created a support file so hopefully that should help!!

Thanks again

M

Okay I can it was removed in Edit Songs report 24 (it was there before that)

Kazoo is misleading since you would have to refresh MinimServer first. Are you sure you cannot see in your Apple Mac now, so the Vaughn Williams folder is just missing, can you recheck.

I have refreshed MinimServer and the Vaughn Williams folder is still there in Kazoo

It the Vaughn Williams folder is definitely not visible on the Mac in Finder!!

I’m kind of stumped, maybe it is a permissions problem but not sure how that could have happened. You could try renaming the Vaughn WIlliams folder as well to see if that make any difference.

If it is a permission issue then there is no way to see the permissions on the Melco directly, the only way I could do it is to create a special test version for you , but that is a fair bit of effort and I am not going to be able to do that this week.