SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Command-line tagging has stopped working

I’ve used SongKong in command-line mode for years. After upgrading to 7.0, no songs are matched anymore and each attempted action ends with an error.

Command-line example: “C:\Program Files\Jthink\SongKong\SongKong.exe” -m “C:\Users\David\Downloads\The Kinks - Dandy.flac”

When I use the GUI, the song gets matched and the song metadata is update correctly.

What could I do to fix this?

I just tried and it worked fine for me

Are you sure you don’t have SongKong already running, maybe try a reboot

Thanks for trying Paul!

I’ve tried again and it still doesn’t work:

C:\Users\David>"C:\Program Files\Jthink\SongKong\SongKong.exe" -m "C:\Users\David\Downloads\The Kinks - Dandy (1).flac"
debuglogfile is:C:\Users\David\AppData\Roaming\SongKong\Logs/songkong_debug%u-%g.log
userlogfile is:C:\Users\David\AppData\Roaming\SongKong\Logs/songkong_user%u-%g.log
Start Fixing Songs
>>>>>>>>>>>>>>>>>>>>>ReportId:13Musicbrainz 0: Discogs 0: Saved 0
Songs Report is:C:\Users\David\AppData\Roaming\SongKong\Reports\FixSongsReport00013\FixSongsReport00013.html
Songs loaded:1
Songs ignored because already matched:0
Songs fingerprinted:0
Songs matched to MusicBrainz release:0
Songs matched to MusicBrainz song only:0
Songs matched to Acoustid song only:0
Songs matched to Discogs release:0
Songs matched with artwork:0
Songs matched to AcousticBrainz:0
Songs saved (if not preview):0
Errors and Warnings:1

The same file was matched to MusicBrainz when I used the GUI instead of CLI.

I think I’ve solved it now. It turns out that the command line only works if I change to the SongKong directory first:

C:\Users\David>cd C:\Program Files\Jthink\SongKong

C:\Program Files\Jthink\SongKong>SongKong.exe -m "C:\Users\David\Downloads\The Kinks - Dandy (1).flac"

In my VB application, I needed to set the ProcessStartInfo.WorkingDirectory property to make it work.

Okay, I didn’t have to do that myself but sounds possible.