SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Blur update annoying 'enlarged' view

Hi, Just installed Blur. Had to rearrange all my preferences, which was a bit of a pain, but I could cope. BUT, annoyingly, about 10 seconds after opening up, it’s as if the window zooms in to about 300%, which means I can only see about 6 tracks at a time, and only a few columns - and there doesn’t seem any setting in preferences (or anywhere else) that I can change that back to how it used to look, and how it looks for the few seconds after I open it.
Anybody else got this problem, and/or got a solution?

It happens to me too but in a different situation (I have not installed Blur): when I change the power supply (from battery to cable or vice versa). Maybe it’s some power saving setting that generates the bug …
It also happens with SongKong but, in this case, not when you change the power supply but during normal use of the software.

With jaikoz it has happened since the UI was updated while with SongKong it has been for a long time.

Hmm, its certainly not a feature added directly by me and it has never happened to me. Maybe related to using a newer version of java or maybe not, what operating system are you both on?

What do you mean - only have having a single tab ? tabs can be modified here.

Windows 10 and Windows Server 2019

No - this is purely about how it views - I have the columns etc sorted the way I like them (or probably the way I got used to them) - but it’s as if the whole window zooms in and enlarges by about 300% - it starts at what was the normal size - I’ve attached 2 screenshots of a full screen to show what I mean - the fist is when I first opens (as it used to be), and the second is as soon as I open something or in any other way interact with the program:

BTW, Windows 11 - most recent update

Not sure what this means

Wonder if you have any modifications to these windows settings

I have it set like this - but I’ve always had it set like this, as I have very high resolution monitors. It doesn’t seem to affect anything else.

Interestingly, if I change the scale in this setting to (say) 150%, all my other apps shrink, but the Jaikoz app doesn’t.

I think this is likely to be the problem. Try closing Jaikoz, setting this back to 100% and then start Jaikoz does it still happen then ?

With these latest versions we have moved to Java 17 and I think it is only with Java 17 that Java takes notice of these Windows settings, but maybe although it takes notice it isnt quite right for you. I expect it only checks when you first start Jaikoz once it is running making modifications to the Windows settings will have no effect.

@Dani82 is this the problem for you ?

Sorry but I’m not at home this week. I can check next week

that seems to be the problem (I have a 4k screen)

Okay, thanks. I dont have a 4K screen so its a bit difficult for me to fully understand the issue. If you have the scale set to 100% how large is the text in Jaikoz app compared to other Windows applications ?

Would be helpful if you could take a screenshot of whole screen showing Jaikoz and another app at the same time.

Hi - I have two houses that I alternate between - one has 2 x QHD monitors (these images), and the other (which I will be at tomorrow) has 2 x 4k. I’m with Dani - the scaling on the QHD monitors is livable - it’s the 4K monittors it gets very difficult.

Hi thanks, so it seems that in both cases the Jaikoz text is generally a bit larger than the Word text. So maybe if I make the text a bit smaller as standard that would work better at 100%, and then be okay when scale upward ?

Dont understand why the Detail Panel tabs at the bottom seems significantly larger.


200% (my standard)

@Dani82 Okay what I am not understanding is that on your screenshot without scaling the text in Jaikoz is slightly larger than the text in the forum, but if I take same screenshot on my 1920 x 1080 monitor then then its the opposite way round, the text in the forum is slightly larger in the forum !

Doesn’t make any sense to me, have you modified the settings in your browser, why in yor first image doesn’t the text make use of all the available space in the browser ?

Okay, I was busy yesterday and couldn’t explain the two screenshots in detail.
My screen has a resolution of 3840 x 2400 and normally the text zoom level is 200%

In this situation Jaikoz behaves as explained in my first post.

I took the first screenshot by changing the zoom of the font to 100% and then restarting jaikoz (the chorme page was already open during the change, so it adapted in real-time).

The second screenshot I did by resetting the zoom to 200% and, this time, leaving jaikoz open without restarting it.
In this case the web page is back to the standard size of normal daily use, while Jaikoz has become much larger (of the same “problematic” size described in my first post)