SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Unable to load songs depending on folder name

After upgrade from 9.30 to 11.7 in Win7, I am unable to load any songs from a folder with a specific name. It was the first folder I tried after upgrade, so for a minute I though I couldn’t load any songs at all, but it’s just this one folder. If I rename the folder it works fine.

The folder is named “~ Soundtrack - Copy”. If I rename to “~ soundtrack - Copy” it works. Very strange, possibly an obscure bug?

Actually, there’s more. Tried another folder, didn’t work, renamed it, now it works. Also tried clearing the cache, no difference.

Hi, simply close Jaikoz then reopen, then before opening any files run Advanced:Create Support Files then you should be able to load all files without issue.

Unfortunately that didn’t work, still can’t open the audio files. Also tried uninstalling/reinstalling, no change. You want the support files?

Thats weird, are you still finding none of the songs that worked before dont work, or is it now limited to a small set of songs.

Yes please run Advanced:Create Support Files and then email the zip file to

I don’t have a large data set to report on, but the two folders (and all the associated subfolders) that were previously failing are still not working. There doesn’t seem to have been any effect from creating the support files, clearing the cache, etc.

The affected folders are temporary storage locations being used while I tag the music, so renaming them to use Jaikoz is not an issue. Primary music folder seems fine (based on some random checking).

Still, the issue is puzzling. I sent the support file via email.

From the logs

20/09/2023 Runtime Exception: in record unable to display corrupt file:\\nas\Media\temp\Thomas Newman\American Beauty\American Beauty - Score - 18 - Thomas Newman - Any Other Name.mp3
java.lang.RuntimeException:; local class incompatible: stream classdesc serialVersionUID = 2980556015887462129, local class serialVersionUID = -6841071554598620169
	at com.jthink.jaikoz.db.SongCache.getSongFromDatabase(
	at java.base/
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/

This error means you are trying to load a record from database that is using an older version of a class then we are now using in Jaikoz. In English this means you have old records in the internal Jaikoz database that are no longer valid and you need to create a new database.

This is normally resolved by running Advanced:Empty Cache as per my earlier instructions. Bu if you are saying this doesn’t work do the following:

  • Close Jaikoz
  • Manaully delete Jaikoz database folder (On Windows this will be C:\Users\username\Jaikoz\jaikozdb where username is your username
  • Start Jaikoz

and that should fix it.

Manually removing the jaikozdb folder fixed the issue. Thanks!

1 Like