SongKong and Jaikoz Music Tagger Community Forum

Trying to get multiple discs to appear as a 'Box set'

I am trying to get multiple discs from a Box set to appear as a ‘Box set’ - there are 17 Disc in this Bach set and I would like it to appear as one "Album’ on the Melco under composer - but then when I click on it for the list of content to be grouped by Disc 1, Disc 2 etc

I seem to have been able to do this before - but not consistently and not on this set currently it is appearing as 2 Albums - and then these are not showing the separate Discs when they are clicked on

Many thanks

MScreenshot 2020-02-09 16.52.39

I have sent an appropriate support file - thanks

An album is identified by the Album title and also the AlbumArtist, both need to be the same for all tracks in the album.

In your case your album artist is split between Johnann Sebastian Back; Peter Hurford and Peter Hurford and this can be seen by using Browse by Artist/Album

It is standard SongKong to remove composer from albumartist so I would remove Bach from the remaining 81 files in Disc 14, 16 and 17.

Displaying discs is a bit tricky. The preferred MinimServer default approach is to just hide the disc boundaries as they could just be considered an artificial construct, this is most useful when a work traverses two discs but this doesn’t usually happen.

To display disc boundaries just having the DiscNo field completed is not enough for MinimServer, you also need to add something to Disc Subtitle, this can be found on the Discs tab of Manual Edit, the disc subtitle should be different for each disc, and the same for all tracks on each disc. This is explained further in the second part of http://blog.jthink.net/2017/06/minimserver-with-songkong-part10.html

(The first part describes an alternative method that appends something to the album name. But this requires SongKong to be able to automatch the album, and is not compatible with non-minim server players it will cause each disc to be seen as a different album.)

But on checking your data you seem to have already done this so I wonder if the problem is simply due to the albumArtist not being consistent, so it may work after fixing that. If it does not work please post a screenshot showing what happens when you expand the album in your music player.

Thanks Paul - not sure how we missed those 3 discs with Johann Sebastian Bach: Peter Hurford as the Album Artist - removing those and just leaving as Peter Hurford means they are all showing as one Album - I already have the DiscSubtitles filled in as Disc 1 Disc 2 etc
The whole thing now appears as one continuous Album which is good - with 327 tracks
Despite having Disc Subtitles as Disc 1, Disc 2 etc it does not appear to be putting in the Disc ‘boundaries’

Can you help with the next step please

thanks Mark

It should work so can you send screenshot showing this on player, also please confirm you are using Minimserver not Twonky and that you have also done Rescan Songs and Playlists from the Melco OLED so that MinimServer picks up all the changes made by SongKong

Hi Paul
I think I may have found a solution if I put [Disc 13] after all the Album titles of Disc 13 then it seems to trigger the Melco/MinimServer to show separate Discs when you look under Complete Disc - Interestingly if you put [Volume 13], And then do something similar for another disc in the collection (in this case Disc 8) then it shows it as a separate Disc in the Composer index view - if you just do it for one of the discs it has no effect

Hmm, well adding to album title is a solution but it shouldn’t be necessary if using Disc Subtitle

1 Like

I have a couple of screen captures with and without adding [Disc x] and [Disc y] after 2 of the discs - will send as soon as I get a chance

M

May have found the problem, these are WAV files and hence use the ID3 format, which can be v22, v23 or v24.

MinimServer only supports DISCSUBTITLE for ID3 v2.4 tagging format https://minimserver.com/ug-library.html#Albums%20and%20folders

so if yours are yours are V23 this will not be supported. SongKong does have an option on the Save tab to use V24 but currently this only applies to MP3 files.

image

The best way to check is to load the files into Jaikoz and see what it has as the tag version in the Version field

and you can change this by selecting drop down and selecting V24 and then File:Save Changes

Alternatively if you set Preferences:Save:ID3Tag V2:Always write tag to V24
then on loading files it will automatically convert them to V24 if they were not V24 on save

Wow - will need to get my head round that!! In the meantime here are the 2 screenshots - with the [Disc x] and without

with

Fabulous Paul!!

That works even better as it shows the ~Discs as soon as you click on the Album/Box set and not just when you go into the ‘complete Album’ mode!!

Fabulous!!

thanks so much
Now all I need to do is remember for next time

Best wishes

Mark

You mean converting to ID3v24 ?, could you show us screenshot to indicate the ~Discs difference so I can pass onto Simon from MinimServer.