SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

SongKong (paid) crashes or freezes repeatedly

Getting really frustrated with this…I am a new user, just got my melco upgraded and purchased a SongKong full license. Trying to just fix art work on my melco database at the moment

Running from a PC using ethernet cable, I can open my melco address :4567 and select fix directory. There are several thousand but repeatedly the SongKong running on PC stalls after a few thousand. I first thought this was due to my Naim app accessing the melco but today, this definitely did not happen. Naim App closed on all devices and I’ve been out all morning.
It has frozen again.
When I click pause to try and restart I get Hmm, can’t access page - refusing access or similar.
Reboot melco and PC worked once.
Just went to melco and found SongKong service was off (it was definitely ON when I started)

What is going ON?

Hi, could you please run Create Support Files so I can look at your log files.

Done, all files uploaded

Thanks, okay so the earlier runs worked against /mnt/disk1/share/import_CD against 10,000 files

but run on 18th failed against /mnt/disk1/share/ CD, it actually run OutOfMemory, i assume this has significantly more than 10,000 files

Because it crashed this caused the SongKong service to stop so was no longer accessible via the webui, you have to restart using the Melco OLED if this happens.

Now, this should not happen, but the Melcos are rather limited in computing power and memory so they are a bit more sensitive to the limits. So I would suggest for the initial fix you would be better off installing SongKong on your PC (license allows this), remote mounting your Melco drive so PC can see it and then fixing using your PC.

Then once major work is done you can use the version installed on your Melco for smaller tasks.

Hi Paul
Actually the smaller task on import CD also failed first time I ran it but was successful later.
Rather than install SongKong on the PC (I may do) would this also work If I did the CD folder in smaller chunks?
I may well install on PC anyway as it’s a very powerful PC

A couple of things failed due to a timeout matching some albums but it mostly worked and didn’t crash. Remember albums are saved as SongKong goes along so even if fails first time, second time round it doesn’t have to rematch the songs already identified and saved

It might, but I think it would be simpler and quicker to use the PC.

Thanks Paul. I’ve installed it on the PC so I’ll give it a go tomorrow

Hi Paul
The tasks completed fine on the PC so hopefully all is well now.
One observation, the app on the PC would not shut down. It had completed and reported but neither File Exit nor red X would close the app. I had to shut down windows to close.


Hmmm, that is wierd could you please run Create Support Files for me because it may show an error in the logs

Hi, Done.
THe occasion it failed to close was yesterday evening (20th).
Note that just before sending I opened to try and close without running any tasks. I accidentally opened 2 instances (too many clicks). One closed, the other would not close again.
After a reboot, tried again without tasks and it closed this time
Platform is windows 11. Intel processor (13th Gen)

Yes it failed to close because ti was unable to release the cache I should ignore error and force close will make a change. It does look like two instances were running to cause that issue, But if you are saying you had the error before that it maybe caused by cancelled task 4.

I saw you ran Fix Songs successfully three times in preview mode, you then ran again but cancelled it and then ran the 5th time with preview disabled and actually did have some errors

I cannot work out if these are due to the previous task hanging around or connection issues to Melco but I would suggest the following to get clean run.

  • Reboot computer to ensure nothing hanging around
  • Mount Melco internal drive to a mapped drive (e.g Z:\ drive) , this always seem more reliable to me
  • Rerun Fix Songs task

Shouldn’t take too long, if you look at your reports you can see the Preview Only runs took about 1 hour, with Preview disabled it took 6 hours. This discrepancy is because you are modifying large WAV files over a network stored on a device (Melco) with a slow hard drive, since most are already matched updated I would expect to take less than an hour this time.

Hi Paul
Yes I ran in preview mode as I put the wrong license code into the PC version and it took me a couple of goes to work out this was the problem rather than a setting error (I used the wrong email).

Connection to the melco is strong, its Cat 6 ethernet all the way.
I have the melco internal drive already mounted (drive Y in my case). It was mounted prior to the runs yesterday.

I’ll rerun the fix songs task. Do I use the default setting again for fix songs or metadata?

Ah, I wonder if the fact that it was already mapped to Y:, but then you accessed it as /mnt/disk1/share/import_CD caused the issue.

Yes, same settings it will skip over matching of already matched songs

Hi Paul
That run completed OK and no errors reported. The app closed too.

Looks OK, I’ll continue and report back if any further issues

1 Like

Close issue now fixed in SongKong 10.3 Blur