SongKong and Jaikoz Music Tagger Community Forum

SongKong on Melco Version Update

My understanding was, that SongKong on Melco N1 is being updated automatically. However, today my Melco was still at version 5.09.

I was trying to update via “If you have previously installed MinimServer on Melco N1” but without any luck.

Afterwards I tried the update via “If you have never installed MinimServer on this Melco N1”.

As a result I can’t access any music, only the files are visible by using the macOS finder. Seems that my MinimServer install is being ruined.

Ideas are much appreciated. Thank you.

I’ll have to test out the updating, sorry we we are still on Beta on N1 and the current install method is meant to be only temporary. But yes if you ‘have never installed MinimServer’ then it will wipe any existing SongKong and MinimServer installations as they used the same installer method, so unfortunately you’ll have to reinstall MinimServer, but this will mean if you then install SongKong you will get 5.12 version (should be 5.13 but not because of other problem).

Thank you very much Paul. I have MinimServer as well as SongKong 5.12 Update and running again:

  1. Reinstalled MinimServer from scratch
  2. Downloaded SongKong for Melco N1 (now version 5.12)
  3. installed SongKong using If you have previously installed MinimServer on Melco N1 instructions

Done.

Please note that macOS is NOT copying the required .Anas.bak folder if you have can?t see hidden files which is the default setting for Mac users. You need to temporarily make hidden files visible:

Open Terminal and run the following two commands:

defaults write com.apple.Finder AppleShowAllFiles true
killall Finder

If you want to switch it back, simply change the true to false.

Merry Christmas everyone.

SongKong 5.13 for Melco has now been fixed and is available for download from http://www.jthink.net/songkongformelco/download.jsp

Updating from Previous Version
I have just tested this and I found that following instructins for If you have previously installed SongKong or MinimServer on this Melco N1 did cause the previous release (5.12) to be replaced by new release (5.13) correctly.

Hidden anas.bak file on Mac
If you unzip contents of zip file to usb drive then this folder should be copied regardless of whether hidden or not. I can only see an issue if you unzip to a temporary location on your hard drive, and then copy the visible files to the usb drive from there.

Thanks for update Paul.

I unzipped the file with my Windows as well as with my Mac - however still the same errors:

01/01/2019 11:39:34:songkong:remote dbinit
01/01/2019 11:40:14:songkong:remote started
debuglogfile is:/mnt/disk1/share/SongKong/Logs/songkong_debug%u-%g.log
userlogfile is:/mnt/disk1/share/SongKong/Logs/songkong_user%u-%g.log
03/01/2019 09:51:05:songkong:remote dbinit
03/01/2019 09:51:45:songkong:remote started
Error: An unexpected error occurred while trying to open file lib/songkong-5.12.jar
Error: Unable to access jarfile lib/songkong-5.12.jar
Error: Unable to access jarfile lib/songkong-5.12.jar
Error: Unable to access jarfile lib/songkong-5.12.jar

…2nd attempt was working well. I have SongKong 5.13 running on my Melco N1.

I was trying to update towards the ELEPHANT release and failed again:

userlogfile is:/mnt/disk1/share/SongKong/Logs/songkong_user%u-%g.log
19/05/2019 16:57:23:songkong:remote dbinit
19/05/2019 16:58:03:songkong:remote started
Error occurred during initialization of boot layer
java.lang.UnsatisfiedLinkError: no nio in java.library.path

Hmm, can you please email me your /mnt/disk1/share/SongKong/Logs/songkong_debug0-0.log file.