SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

SongKong not installing on Melco N1A


I’ve recently acquired a second hand N1A which is running Melco’s latest OS 3.93 and I see that there is an option to configure SongKong. When I take the option to use the SongKong service, a few seconds passes and a messaged is displayed indicating that the installation was successful. However, when I go back in to the SongKong Service menu, the Asterisk is against the ‘Off’ option.

Also, looking at the SongKong folder on the Melco, the database has not been updated and I cannot access the SongKong web application via port 4567.

Any ideas? Has the installation been corrupted? Can I reinstall?

Thanks in advance :slight_smile:



HI, ok can you please email the contents of the SongKong folder.

Thanks - I’ve just sent the email…,

Okay so there is no Logs directory then?

Have you tried restarting SongKong from the service menu, if not try and then wait 5 minutes before trying to access on port 4567.

If you have already tried that, try manually deleting the Melco SongKong folder form your copmputer, and then restarting. There is no way to remove the installation and reinstall on a Melco, but this step will cause the existing SongKong installtion to rerun its initiialization code.

I’ve deleted the SongKong folder and tried to reinstall via the Service Menu but the options runs very quickly - just a few seconds but still the asterisk is not against option 1 and there is no new SongKong folder on the N1A.

Okay I will have to think about this, sorry I don’t have an answer for you at the moment.

Sure, no problem - Thanks for checking

But Im not sure of problem, difficult to diagnose Melco problems, but there is a new version of SongKong available can you try and install that.

Many thanks for your help with - The new version of SongKong now up and running :grinning:

1 Like