SongKong and Jaikoz Music Tagger Community Forum

scanning songs to match complete Album - Move - but do not overwrite active artists

Hi, I would like to create two folders (which I have already) one complete Album list and one incomplete album list folder.

I am scanning a directory and would like the music to be grouped and saved by Artist (or Various Artist) if its complete or not complete.

I have quite a few different directories I would like to scan. Does Song Kong look in the folders and notice a folder already containing ‘Gregory Isaccs’ so does overwrite the artist name with a new scan made.

Basically I would like to keep using the ‘File Moving’ folder I made (Complete Albums) and let Song Kong check the folders, if the artist already exists, check the album name… if that exists check the quality and then choose whats best.

thanks

lister

This is what I would suggest:

Create a new Folder Complete Albums
Configure suitable Rename mask for what you want
Configure SongKong to Only allow match if all tracks in album were matched to ensure only full albums are matched.
Configure File moving:Move Folder to point at Complete Albums
Then run Fix songs, you should just be left with songs that could not fully match an album.
Then Create a new Folder Partial Albums
Disable Only allow match if all tracks in album were matched
Configure File moving:Move Folder to point at Partial Albums
Run Fix Songs again
Now left with songs that could not be matched

So your songs are now organized:

Full Albums
Partial Albums
Unmatched

Hello Paul,

This isn’t working for me. I’m running 6.8.2 on a Mac.
SongKong is moving all files, regardless of whether or not their albums are complete. I’ve constructed a test folder of incomplete albums.
My goal is to kick out any albums which are incomplete—or, inversely, are complete.

Any thoughts?

Can you run Create Support Files please and point me towards an example folder that should not have been moved but has been.

Done. Sent a Dropbox link to the lates test files. Thanks for your help.

Looking at your last few reports I think I know what the issue is.

The files seemed to have been renamed to the COMPLETE folder, but no metadata has actually been added or updated. So this indicates the files were already matched to a MusicBrainz album and therefore when you ran this time when it gets to the move file stage the file is moved because it has already been matched to an album

So I assume at some point you did not have Only allow match if all tracks in album were matched set to Yes and that allowed these incomplete albums to be matched to the correct album.

Its worth noting that SongKong only adds/updates data it doesnt just delete data so if you wanted to prevent SongKong thinking these songs were matched to an album you would need to delete the existing MusicBrainz metadata (specifically MusicBrainz Track Id and MusicBrainz Release Id).

An easy way to delete all the metadata is download Jaikoz and select Edit:Delete All Metadata

Thanks.
That doesn’t seem to work if there are any subfolders.
For instance, I have a tree:

INCOMPLETES folder
-Rattlesnakes folder
–1 Song-Rattlesnakes 1
–2 Song-Rattlesnakes 2
–5 Song-Rattlesnakes 5
–9 Song-Rattlesnakes 9
-misc song1
-misc song 2
-misc song 3

The misc songs get left in place, unaltered.
The Songs in the Sub-folder, Rattlesnakes, get moved to Complete, even though there are songs missing from the album.
If I move the Rattlesnakes files out of the sub-folder, into INCOMPLETES, they are not moved when I run SongKong.

I’m deleting all metadata after each test, and I have SongKong’s “For songs already fully matched” set to “Rematch”, just in case.

The SongKong preference “All existing folders represent a single album” is OFF.

If you have just run this test as you described please run Create Support Files again and tell me the name of the report so I can check it.

Report 298 in the support files I just sent.

Okay I have looked at your report, this should not happen, could you try running File:Empty Database and then rerunning the test to see if that resolves it.

Same results.
Downloaded and installed new version, emptied DB, quit, restarted, ran it on files containing no metadata.

Ok, sorry but there is not info in logs for me to work out why this is happening.
Can you go into Preferences, set Debug Log Level and Debug Io Log Level to Config, rerun the test and then send the support files again immediately after.

Done. Report #303. Database emptied and SK restarted before running tests.

Hi, I think I have found the error.

The Only allow match if all tracks in album were matched options behaves slightly differently if the album is a multi-disc album. Customers may have their multi disc albums stored as different folders not below a common parent folder in such cases it is difficult for SongKong to realize these folders are all part of same album so instead what would happen would be the folders would be matched to one disc of the album independently. So in the case of a group of songs matching to one disc of an album it is okay if the group of songs doesnt match the whole album as long as they all match the same disc of the album, however there is no check to ensure that all tracks on that disc are matched, this seems to be an error.

So this allowed your tracks to match the multi-disc version of Rattlesnakes (good album), the regular discs were rejected because album track count did not match song track count.

I am going to try to do a fix for you to try (for MacOS ?).

Yes, Mac OS. Thank you very much.

Okay I have fixed and test this, but I have a couple of other problems that came up today that need fixing so I am going to roll them all up into a 6.9.2 fix which should be ready in a couple of days.

Hi @pixeljammer now fixed, please give it a go

Thanks, that solved my problem.

Thanks for making a great product, and double thanks for the excellent customer service.

It doesn’t seem to work with all files. I’m getting the same results with other files, but not with Rattlesnakes… I updated the Dropbox folder with some files that cause a failure. I’ll reiterate the address in my Support Files.

Hi

It because they are single files. Of the five files that were moved, the Blade Runner match is a complete match I don’t think there is any issue with that ? The other two are single files, the logic is that seeing as you only have a single file its better to add the album info rather than the just the song info so at least you have a chance of getting the right album artwork ectera.Then because they have been matched to an album that allows them to be moved, as that process is just concerned about if they have been matched to an album (rather than if it is a complete album).

Of the ones that didn’t move, the Bille Holiday tracks could not fully match an album so they correctly were not moved. The other single track was not moved because it could not be indentified.

So, what is the solution ?

We could prevent single songs being allowed matching to match to an album (unless 1 track album) but I do not see that as an improvement. Better I think would be to amend Move Folder option so you could choose whether it applied to all albums or just fully matched albums ?