SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Rendering Issue

I’ve re-installed Jaikoz (last version file) to make sure it wasn’t coming from the update process and now I am getting the error (many windows of the same msg) shown in the screen print at opening the app and also while adding files…

Again, my old version of Jaikoz was working fine until I update to the latest.

There is something going on here and I need your help to fix it Paul.

Thank you

Hi, this is different problem I need your support files so I can see where the errors are occurring.

Run Advanced:Create Support Files and then email the zip file created.

Thanks for the logs, the error is

java.lang.ArrayIndexOutOfBoundsException: Index 837 out of bounds for length 789
	at java.desktop/javax.swing.DefaultRowSorter.setModelToViewFromViewToModel(DefaultRowSorter.java:745)
	at java.desktop/javax.swing.DefaultRowSorter.rowsInserted0(DefaultRowSorter.java:1078)
	at java.desktop/javax.swing.DefaultRowSorter.rowsInserted(DefaultRowSorter.java:879)
	at org.jdesktop.swingx.sort.DefaultSortController.rowsInserted(DefaultSortController.java:404)
	at java.desktop/javax.swing.JTable.notifySorter(JTable.java:4332)
	at java.desktop/javax.swing.JTable.sortedTableChanged(JTable.java:4180)
	at java.desktop/javax.swing.JTable.tableChanged(JTable.java:4457)
	at org.jdesktop.swingx.JXTable.tableChanged(JXTable.java:1647)
	at com.jthink.jaikoz.table.tablemodel.TagDisplayModel.fireTableChanged(TagDisplayModel.java:182)
	at java.desktop/javax.swing.table.AbstractTableModel.fireTableRowsInserted(AbstractTableModel.java:237)
	at com.jthink.jaikoz.data.AudioDataModel.fireTableRowsInserted(AudioDataModel.java:123)
	at com.jthink.jaikoz.data.AbstractAudioFilesLoader$1FireTableRows.run(AbstractAudioFilesLoader.java:129)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:318)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:771)

Its related to rendering the content, but not clear to me the circumstances causing this.

If you restart I assume it doesnt happen, or it does can you give me details of exactly what you are doing, do you have some columns sorted, or rows filtered ?

Hi Paul, as I explained initially this is happening while adding files in Jaikoz. I’ve restarted and it’s still happening for every added song (new screen print attached)

David

I need more details

You open Jaikoz and it is okay
Then you select Add Files and you get this error?
Are you filtering songs before you do this, does problem occur if you use Open Files /Open Folder / Add Folder?

  1. I open Jaikoz
  2. I drag & drop a list of files or whole folder onto Jaikoz
  3. error msg appear

Okay so try not using drag and drop, instead use Open Folder, does that work for you?

Hi Paul, it seems to be better but I still get the error after working for a while on the files.

Am I the only one getting this error?

Yes, it’s not clear to be what is causing the issue, can you work out when it first occurs?

it started when I installed the latest version. I was using an old one before

That doesn’t help, Ineed to know what is the thing usually do just before it starts happening for first time

ok. I didn’t understand your question as I thought you were asking when this started to occurs…

Well as an exemple, I have been working with the app for some time, importing and working on files without any issues, and all of a sudden I import files as I’ve been doing for the last couple of hours and the error pops up for every imported files without even starting working on them.
What I do is closing the app, restarting it, reimporting the same files in the same manner and all is working fine again…
I tried deleting cache instead of restarting the app but that doesn’t help

Does it only happen if drag and drop?

no, I’ve tested this after having imported a whole folder including 5000 files before going to bed and I get the error this morning while sorting columns…

Ok, it probably is sorting related, we made massive changes to support multi column sorting and it has proved difficult to resolve all issues, if you try not sorting does that avoid issue?