SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

On Windows Jaikoz complaining about ITUNES_MODEL does not exist when run Empty Cache after upgrading

If upgrading from very old version of Jaikoz you may find that Jaikoz seems unable to load files it could load previously. The solution to this is usually to run Advanced:Empty Cache but in some cases when upgrading from particular versions this can give error

If this occurs you need to manually delete the cache as follows:

  • Ensure Jaikoz not running
  • Open Windows Explorer
  • Go to C:\Users\username\Jaikoz where username is your Windows username
  • Delete folder jaikozdb
  • Start Jaikoz

I’m having this problem on a Mabook Pro after upgrading to 11.6.2 Pulp.
I get the error message…
ITUNES_MODEL does not exist: com.:jthink:jaikoz:db.Db.emptyCache(

This happens when I run Advanced -> empty cache.
How do I manually clear the cache on a Mac, please.


2015 Macbook Pro
MacOS Montery 12.6.1

So it doesnt happen when yo first run, only when you run Advanced:Empty Cache ?
That is weird because it should run Empty Cache as part of upgrade so I would think you would see error then, anyway on a Mac do the following:

Stop Jaikoz
From Finder , hold down Option Button and select Go menu
Select Library from the list
Got to Preferences : Jaikoz folder
Delete jaikozdb folder
Start Jaikoz

Thanks, that did the trick. It actually did happen when I first ran it, and then I came across the suggestion that I empty the cache on this forum and it happened again when I tried that. Seems to be working fine now. Thanks again.


1 Like