SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Multi Disc albums not matching with "Match Songs to Specified MusicBrainz Album"

I couldn’t find anything back when I searched the forum so appologies if it’s a known issue, but whenever I use the action “Match Songs to Specified MusicBrainz Album” on a selection of files from a multi disc album, I always get a

So take this as example, where you can see a 2 disc best of album of R.E.M. It’s been matched already with Discogs, and next I searched for the specific release on it on MusicBrainz:

So I selected all the 33 songs of the album, went to action “Match Songs to Specified MusicBrainz Album” and entered the Release ID:

But this always results in the “Unable to find a suitable release for the selected songs” message:

I never have this for single disc albums, but always for multi disc albums. Sometimes I do get a hit but where it mismatched ALL songs so it cannot be used either.

As you can see from the initial screenshot, all information is available already: track number, disc number, but also the number of discs is filled in (not in screenshot).

The only work around I found so far is to then manually copy paste from MusicBrainz the “MB Track Id” in each of the songs and then to a “Update Metadata from MusicBrainz” actio, at which point it is retrieving all the information correctly, but which is VERY time consuming.

Is this a known issue? Am I using it incorrectly somehow? Is there a work around possible?

Any information would be appreciated very much.

Not sure, does it work if you don’t one disc at a time?

If you mean selecting the songs of one of the disc only and then doing the same action, then no it does not match it then either.

Here you see an example of another 2 disc album where I only selected the songs of the 1st disc and matched it with a specified MusicBrainz album and it mismatched all of the songs:

Also here the “Match Song to Specified Discogs Album” worked without any issue.

But perhaps I misunderstood your question?

Okay seems like a bug, raised but have not had time to look into it yet but will try later this week.

In the meantime try Action:Remote Correct:Manual Edit from MusicBrainz , this is semi-automated

Great, and no hurry needed, just thought I’d check in case it was indeed a bug :slight_smile:

Thanks for the alternative, I’ll have a look into that one, never tried that option before.