SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Missing match on Discogs (I have catalog number and Discogs ID)

Hi There, Is there a possibility to manually provide a Discogs Release ID?

I have the situation that my album is not recognized. I tried the Ony Album Only function.

Album on Discogs

I made sure that the folders, filenames and metadata equal the information in Discogs. Including the catalog number. Somehow it is still unable to find a match.

Because I get this warning before finishing the wizard, there is no log file available to upload.

What about if you use the Match to One Album task, does it come up then?

Hi Paul, Thanks for your reply. Yes, I intentionally tried that ‘Match to One Album’ task. That is, why I do not have a report. Because it gives the ‘No match’ message and does not create a report.

I do think it is a nice improvement if one is able to manually provide a Discord (or other) Identifier, so that you can help or direct the automatic matching.

Is there anything else I can do to help troubleshoot this?

Okay can you run Create Support Files then I will be able to see in logs why no match found,don’t need a report to be created to upload log files.

Are your track lengths correct, tracks lengths that differ by more than 10 seconds from the release will prevent a match.

Yes, I did consider allowing Id to be added but was concerned about making ui overly complex, may add at some point.

Great! I did a full run, so the errors are included now. I added the support files.

I understand your opinion about making the UI overly complex. But I do think it is really something to consider. It could be a tab in ‘Match one only’. And we are talking about 2 textboxes.

It seems the original issue was that it was searching for albums by Albert Verline, but it is credited on Discogs to Cast Anastasia Musical Nederland

I see in EditReport you then fixed that

and then you tried again, and it still didn’t work

This seems to be a different issue, the query does a range match on numtracks which doesn’t seem to work properly, if I change to exact numtrack match then it does work, this seems to be a bug.

I see you are on linux, if you like I could upload a new version of Atomizer release for linux with a fix to see if that resolves the issue ?


I can see here that if you could specify Discogs Id you could have resolved yourself without even having to modify the metadata so have also raised

Thank you for you amazing fast response time.

Yes, a fix would be great. I am using the docker container though, but it is no problem to run an instance local for some troubleshooting. No hurry though!

Okay, I think im just going to fix as part of usual release, and also try to add the Discogs Id/MusicBrainz Id option.

Sure thing! That ID override would be great. :wink:

Okay now added the ID override in new release