SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Meta data and file structure

I have just downloaded the 10.1.2 Moose release and have a question.

How do I set up preferences to give me the ability to correct meta-data from files that I have structured using the following format?

Track#-name.

Hi, if you set Preferences:File and Folder Correct:Correct Metadata from Filename:Rename Mask to %trackno%-%title% and then run Action:File and Folder Correct:Correct Metadata from Filename that should do what you want.

Yes, I tried that but it didn’t work. It refused to read the file name.

Try shutting Jaikoz, reopening and retrying I think there maybe some sort of caching issue when you change this mask.

Hi Paul, I did as suggested and it did not help. See attached. Thanks

A post was split to a new topic: Jaikoz rename masks

Okay it worked for me so maybe you could email support@jthink.net an example file over and I will retest to see if I can get it working.

Is there any update? Thank you

Sorry, Im on holiday for a week, will have to look at this when I get back.

At first I would uncheck Only populate fields if empty.
If that doesn’t help I would try to change some files to track# - name
and use the mask %trackno% - %title% and try again.
This mask works for me all the time.
good luck.

Hi, okay there are two issues

  1. The files you gave me have a space before the hyphen (e.g 09 -Waltz in d minor Op.39.) so the Rename mask should be %trackno% -%title% not %trackno%-%title% (note the space to the left of the hyphen)

  1. However there is a bug that means changes to the Correct Metadata from Filename Rename Mask will not take affect until you restart Jaikoz, I have raised a bug and fixed for next release - https://jthink.atlassian.net/browse/JAIKOZ-1322

So in the meantime you need to modify your rename mask, then restart Jaikoz and then it should work for you.

Now fixed in Jaikoz 11.0.4 Tad released June 7th 2021