SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Mac Sonoma / External Lacie HD

Hi All ~
I have a very large archive of music that I am scanning with Jaikoz in sections of 5–10K songs at a time. The scanning works well and is swift. I have two questions.
Environment: Mac Sonoma + Lacie 30TB external HD. USB C connection.

  1. When I choose “Save Changes,” the process appears to go well, but according to the “Last Modified” tag within Sonoma/Mac iOS, the files have not actually been modified. Does Jaikoz automatically write data to the files if “Save Changes” is chosen?
  2. This is a much bigger issue. Every time I scan one of my 5K bundles of files and press Save Changes, I then go back to the external HD to choose and scan the next bundle, but now every folder on that HD is either listed as empty or absent. The only way to read the disc fully again is to eject/reload/remount it. That’s not usual, surely? The UBS cables are bran new and the health of the HD has been checked with Disk Utility. The iMac is new(ish) and trouble-free.
1 Like
  1. Yes, but only if metadata or filename has changed, you can force save even when no changes using Force Save

  2. I don’t understand what is happening here, please run Create Support Files and post a couple of screenshots to clarify the issue.

I bought some (even newer) cables, to see if that helps first.
In the meantime, this popped up.

Can you run Create Support Files please.

Generated and auto-submitted

Hmm, sorry I have no idea why you are having this issue there is very little in the logs, but it does seem to be some issue with your disc.

It would be interesting if you ran SongKong Lite over it to see if that has any problems. You may also want to consider switching to SongKong as that is more designed for super large collections than Jaikoz and you wont have to break processing into batches.

That’s OK. Every solution that doesn’t work is one step closer to an answer. I’ll try running SK on the same database. If I uncheck Preview Mode, then changes are written to/automatically saved in the files, so no further action is needed from me, correct?

Yes that’s correct, but you need a license to uncheck preview.