SongKong and Jaikoz Music Tagger Community Forum

Jaikoz Memory Issue

v10.0 (1165)

I have several different collections with songs totally 30k, 45k, and similar. When I go to try and process them with the automatic settings I let it run all day and night and when I came back my PC was frozen and I had to reboot. Then I tried it again and it got hung up on step 9 of 11 I believe. If I run just a Discogs match it seems to plow through that relatively quickly and doesn’t hang my PC. I ran Task Manager on another monitor so I could see what might be going on and I noticed one time that Jaikoz was running but no longer listed in Task Manager. I have a pretty decent system:

Windows 10 Home
Intel i7-8700k 3.70Ghz
16GB RAM

In addition to my issues I would like to suggest a “pause” button during processing so that I can use my PC when I need to and possibly resume when I am finished.

With default settings you should only load about 20,000 songs into Jaikoz, 40,000 is too many because the amount of memory Jaikoz uses is proportional to amount of data that exists in the loaded files.

Also, Jaikoz doesn’t have access to all your systems memory, assuming you are using 64bit version (32bit version only uses 800MB) by default it will use a maximum of 75% of your system memory,

On Windows in the installation folder in the same folder as Jaikoz64.exe is a Jaikoz64.ini file.Within Jaikoz64.ini edit the value of:

vm.heapsize.max.percent=75

to specify the maximum percentage heap size in megabytes.

Okay I will try this! What should I set it to and how do I only load 20k songs?

I would just try loading 20,000 songs, either by:

  1. Selecting Open Folder and pressing Cancel when Songs loaded so far is about 20,000 songs

image

  1. Instead of selecting your music folder you can selecting multiple folders within the music folder.