SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Jaikoz and Mac OS 11 (Big Sur)

Hi, I’m wondering whether Jaikoz has been tested on Big Sur?

Ever since I updated Mac OS, I’ve been unable to use Jaikoz. It opens, but then, if I try to open Preferences, it freezes. (Using Jaikoz without touching the preferences menu is difficult to say the least.)

Is this a known issue? I haven’t been able to find a blog or forum post about it.

No it hasn’t been tested against Big Sue yet, unfortunately Apple seem to make a habit of breaking things for developers with each release.

I will try and test it out tommorrow.

Very appreciated! Thank you, sir.

Problem, my mac does not support Big Sur so I cannot even try it out currently.

Your issue correlates with a problem encountered by another customer who has moved to MacOS Big Sur, so does seem there is a problem with Jaikoz on Big Sur. I am going to have to invest in a new computer in order to get Big Sur, so in the meantime I would recommend you do not upgrade to Bug Sur if using Jaikoz for the moment.

I don’t know if there are any issues with SongKong and Big Sur.

No … it doesn’t work for a number of functions such as the “control” F edit function. Based editting functions will work but you’d better save after each edit cuz sometimes the app just locks up.

Okay thx, we have a further problem which is delaying purchase of a machine capable of running Big Sur. New machines use the G1 machine but currently Java is not avaikable for G1 processors, but I expect will be soon. I could purchase an Intel based Mac to run Big Sur in meantime but then I would have to purchase a G1 as well at later date, and that is not financially viable.

Bug Sur. Love it.

Thank you for the info, Paul. Love your product; been using it for years and will continue to.

Okay so I have discovered http://www.macincloud.com and this enables me to try out Jaikoz on different versions of macOS such as Big Sur. I tried it and had no problems including when opening preferences

So I think you are just hitting an existing problem whereby if the settings.jai file gets corrupted there is a problem with preferences, this can usually be resolved by deleting settings.jai in your Jaikoz Library folder
then they will be automatically replaced by Jaikoz with a clean version, please try the following.

  • Close Jaikoz if running
  • From Finder menu select the Go menu
  • Hold down the Alt key and the Library menu should appear in the list, select this
  • This will open a new Finder window
  • Select the Preferences folder and then the Jaikoz folder
  • Delete settings.jai
  • Start Jaikoz

It seems to work okay with by limited testing (but I am slightly constrained by using remotely with macincloud rather than having a physical machine). Could it just be that you are loading too many files (the more files loaded into Jaikoz the more memory it requires) and this is not a Big Sur issue at all ?

Hello. Unfortunately, this doesn’t seem to do the trick. I deleted the settings file, restarted Jaikoz, but again, the program became stuck once I tried to do something like open Preferences.

I made a screen recording of it. Would it help at all if I shared that with you?

Yes, it may help thanks.

Watching your video it seems that opening Preferences is fine, the problem only comes when you to try and close it ?