SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Failed to launch JVM

I have been using SongKong for a long time. Version 9.3 Pro since August 2023.
Today I wanted to install Song Kong 10.6 on my new Windows 11 pro 64-bit laptop and I get the error message:

Failed to launch JVM

I tried the workaround with .accessibility.properties, but that didn’t get me any further.

Suggested solution?

So it failed during install rather than after installl ?

Try running install from cmdline to see if that gives any more details.

Thank you for your quick reply.

The installation itself went smoothly, but the error message appeared when I started the program.

I reinstalled SongKong, but uninstalled it first as described in the Song Kong setup. Unfortunately with the same result.

I have no idea how an installation from the CMDline works, sorry…

Okay from your original post it sounded like install failed but if it didnt that is fine, so okay reinstall if not altready installed.

Then open Cmd tool and type

cd "C:\Program Files\Jthink\SongKong"
SongKongDebug

then copy the output and paste it here in the forum

Ok, the problem is basically solved!

SongKong really wants administrator rights.

I am always logged in as a user. So I logged out and logged in as admin to do the CMD thing. But before that I tried to start SongKong and there was NO error message!

So I logged out as Admin again and logged in as User and selected Run SongKong as Administrator, then it works.

However, this is not very practical because you always have to enter the admin password when starting SongKong.

So this is not user-friendly, it was better in the previous versions.

Nothing has changed in that respect, no need to run as administrator usually so not sure why you are having this issue.