SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Endless problems with Songkong

As a computer user with nil knowledge I have previously purchased Songkong and failed to get it to work but decided to try again and once again I am completely lost. I have tried to run the ‘fix songs’ option a number of times and each time the program fails to complete and refuses to pause or stop and results in me having to close the programme altogether following which it won’t then open and I get a ‘child process exited with code 100’ error message.

The one exception to this ‘fix songs’ procedure was when the procedure terminated part way through with a message saying it had stopped because of an unreported error or words to that effect.

I have less than 5000 songs on my Melco and I use Auralic’s Lightning DS to build my database but this results in some double albums being combined, some single albums being split into two separate albums and I have a number of examples of missing or incorrect artwork.

I was hoping Songkong might help with some of these issues…

Okay, can you please run Create Support Files so I can have a look at your results.

Could you please explain how I do this?

Select the Create Support Files option from the top menu, then you just have to select ok to upload your reports so I can see them

Hi, thanks for your support files, I notice a few things:

You are running SongKong on Windows and connecting over your network to your Melco disk. Did you realize that SongKong can be run directly on your Melco, you open your web-browser on your pc and then in the url put melcoipaddress:4567 (the melco ipaddress should be displayed on the front of your Melco OLED). So although you are still using your PC to control SongKong all the processing is being done on the Melco itself and when it read/saves and renames files they are now local to SongKong rather than SongKong having to do this over network.

So although Melco cpu is very slow compared to a PC because you eliminate network traffic when accessing the music files itself it is preferred method.

If you want to continue with using PC that is fine but I would make two adjustments

  1. Set Rename Files from Metadata to No because most of the errors in FixSongs00013Report are mostly related to file naming. (In the next version of SongKong we actually move file renaming out of fix songs and into a separate task because FixSongs currently doing too much)
  2. Map Melco network drive to a drive letter so can access it as *Z:* ectera, this works more reliably.

I see you have run Status Report, that is useful because I can see the contents of your files. But could you point me towards some of your problematic albums as they are difficult to find.

Also you say you are using Auralic’s Lightning DS, but this is only a control point , its builds its internal database based on the information served by the uPnP server, and this will be either MinimServer or Twonky if using a Melco. So when you make modifcations in SongKong you then need to rescan with MinimServer or Twonky so that their database is up to date.

Thanks for the feedback and helpful tips Paul. I was not aware of the option to run SongKong directly on my Melco and so will give this a try.

I presume doing this will remove the need to set Rename Files form Metadata to No?

I have been mapping a network drive to create a share file preceded by the letter Z and I am aware of the requirement to rescan minimserver after making any changes.

With regard to the problem albums I can investigate and list them individually if that is needed but the general issue as detailed in my original post is that numerous (but not all) double albums are combined into a single album where track 1 from each album are listed consecutively, then track 2 from each album and so on. Furthermore, there are a small number of single albums where two albums are produced where one album may show say tracks 1, 2, 3, 4 and the second albums shows the remaining tracks. I hope that makes sense.

Please let me know if you would like me to list the various double and single albums or would you suggest I try running SongKong directly on my Melco and then running the Fix Songs option to see if that resolves any of these issues first?

Hi, I would still recommend you disable rename files for first run because although Melco avoids the network issue there is still the issue of SongKong renaming files whilst processing other files and if you have multiple copies of any songs that can cause conflicts when renaming. So better to run Fix Songs without renaming, you can always rerun later with renaming.

So with double albums, it maybe the issue is with your control point. Because the correct way to number mutli-disc albums is by use of Disc No and Track No, so each disc labels the first track track 1 but has different disc no, whereas it sound like you are expecting all tracks to have different track no ?

It would be helpful if you could give me a specific example so I can check what is stored. I assume you are seeing the problem on your control point, rather than when browsing results in SongKongs own report.

And give me an example of the other album issue.

Apologies Paul for wasting yet more of your time but despite repeated efforts using different browsers I have not been able to run SongKong directly from my laptop. When I enter the
melcoipaddress into my browser I get similar results saying I am trying to connect to a private address with some results indicating the need for username/password etc but nowhere do I get the option to enter that information in order to proceed.

I therefore decided to enter ‘No’ into the rename files and have just run FixSongs. Once again just over 50% of the songs were loaded and then the program stalled and went nowhere for some 30 mins whereupon I was unable to pause or stop the program or click the red X to close the program. I stopped it via the red X button on the main dashboard.

Any further suggestions?

I think we need to work out why accessing via your browser not working, there is no username/password necessary, should be doing something like this

Also SongKong needs to be actually running on your Melco, see How do you restart SongKong Service

Went to SongKong service on my melco and it was already showing as On. Still waited some 5 mins before trying to connect and immediately got the same message as earlier today ‘We can’t connect to the server at’

Have tried a number of times with same result.

Are you adding the :4567 at end of ipadress as detailed and shown in my screenshot?

Yes I’ve added every time

Can you please show screenshot of your browser window because I’m not convinced you are entering the correct url.

I was entering the information correctly and finally managed to open SongKong on my Melco. However, in so doing it wanted me to purchase a licence even though I’ve already got one?
I subsequently ran into a number of other issues and rather than listing them here I thought it might be easier to talk to you at the Signals Hifi Show today which listed you giving a workshop. It was explained that you were unable to attend the event but the workshop went ahead and I did pick up some more information and so will see if I can make any further progress before taking up more of your valuable time.

You need to enter the license information. Even though you have purchased a license your Melco is not going to automatically know this, you have to enter the license information

I’m very surprised I was listed at Signals show as I told Melco I would not be able to do this some time ago.