SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Acoustid problems after computer switch

After a computer upgrade (MacBook for MacBook pro) I found that Jaikoz is unable to retreive MusicBrainz (command-2) id and fingerprints. The message says “Retreive AcousticIds was unable to find a match for n song. Completed retreival of Acousticids fingerprints and Ids for n songs”

I tried to uninstall and to install again checking all preferences again but the problems didn’t solve but now I have also the problems that the view panel is hidden and I am no able to show it with arrows on the left.

Can you help me?

Hi, okay the View panel issue is fixed in Jaikoz 11.3.1 just released today

Please install this and see if you still have your other issue, if you do does it work if run using the menu rather than shortcut keys, if not please run Advanced:Create Support Files and email it to

Thankyou for your support files, the message I get in the logs are

> 18/03/2022 14.12.16:com.jthink.jaikoz.manipulate.acoustidhelper.AcoustId:generateFingerprint:WARNING: Unable to create AcoustID Fingerprint for:0:/Volumes/FinBull - Dati/Music/Ligabue/Miss Mondo/13 Miss Mondo.mp3:No output received

Since you mention you have switched computers I think the issue is probably your Anti Virus software preventing contact with - please try temporarily disabling antivirus to see if that resolves the issue

Thanks a lot, I’ll try to disable all the possible blocks and see…

Again thanks!

Hallo, I write you again because the problem is not soved.
Let me give you some more hints to find the problem.

  1. I tried to disable all filters and firewalls but nothing happened
  2. Looking at the real time connections from LittleSnitch there are no attempts to connect with when both fingerprint and id are missing
  3. When I try to retrieve the id when I have the fingerprint all works right

So the problem seems to me only in fingerprint generation. Is this a remote task or it happens somewhere in my mac?
If it’s a local process may be in conflict with some other software or just the new processor.
If you have some more suggestion to try to solve the problem they will be very welcome

HI, thanks for your analysis.
Fingerprint generation is done locally by making a call to the fpcalc program (a c binary) to generate fingerprint and then that submitted to acoustid to get an acoustid

Just had a thought, are you on a MacBook M1, its just occurred to me that maybe fpcalc is not compatible with M1 chip.

In any case it would be useful if you could send me your support files (Advanced:Create Support Files)

Yes, I have a MacBook M1. Just sent you the files.

Thanks a lot for your prompt response!

Hi, okay I think it is that, a Mac M1 version was released in December 2021 - I will try look at this tomorrow.

Confirmed Acoustids not working on my Mac M1, so I will work on a fix today but because the Acoustid output has changed a little between the version used by Jaikoz and the current version there is more to do than just change the fpcalc binary.

1 Like

Hi, this is now fixed - Jaikoz 11.4 Blur released March 19th 2022

1 Like

It Works!!! :star_struck: :grinning:

1 Like

Great, surprised this hasn’t come up before to be honest thanks for bringing it to my attention.