SongKong Jaikoz

SongKong and Jaikoz Music Tagger Community Forum

Jaikoz unable to contact server MacOS

New MacBook M3. I’m getting the "Unable to contact server. Remote Correct is not available. . . . . " message. I got to File>Update License and select my license.jai file and get “Full License has been Installed Successfully” message. When I load and try to use Autocorrect, I don’t get anything corrected from MusicBrainz or Discogs. I’m wondering if this is a Java 21 issue. My Jaikoz version is 11.8 Belly Build1189. This happens always; I’ve never been able to Autocorrect on this M3 Mac.

Hi, please run Create Support Files

I can’t. It’s grayed out. I sent an email last weekend with some info from console. Should I resend it?

Paul, do you have a resolution for this issue? It looks like Jaikoz is not recognizing my license. About Jaikoz shows that I have a full license but it doesn’t show an expiry date like on my other Mac.

The Java 21 issue was to do with installing a license from file browser on Windows has no effect on licensing, looking at your logs the error is coming from the license server

05/04/2024 16.16.09:com.jthink.jaikoz.settings.VerifyOnline:checkVersion:WARNING: Verify license failed:Error writing to server Error writing to server

The only reasons i can find for this happening is if the data is too large, which make no sense. I am stumped as to why with same license would be find on one computer but not the other.

Unfortunately I no longer have server logs for 05/04/2024 so if you could retry and resend the jaikoz debug log again i can search for a linked error in the license server logs to see if it gives us any more information about the cause of the issue.

I have also just updated my mac to latest version (14.4.1) so same as yours and Jaikoz continues to work without issue.

Retried with the same result. The Upload button won’t allow me to attach text files, so I sent them via email. Thanks.

I cant find any errors on server, Im sorry I dont have any idea why there is issue , but you say it works fine with same license on other servers so it seems issue is computer specific, but can you email me your license file so I can see if it works for me.

Hi Paul, I emailed you my license. Good luck!

Just tried and it worked no problem, okay so maybe there is problem with Virus checker or some network restriction you have on your Mac that prevents Jaikoz checking of license ?

4 posts were split to a new topic: Unable to access Jaikoz

It started working over the weekend of 4/20. I’m not sure why unless it’s the license server. The options are no longer grayed-out and About Jaikoz shows when my free version updates expire. Thanks for getting this issue solved.

This issue returned after I rebooted (M3 Mac). My other Mac (Intel) does not have this issue.

Can someone please check this?


I think the issue is specific to your computer did you look to see if there is problem with Virus checker or some network restriction you have on your Mac that prevents Jaikoz checking of license ?

It was working correctly for a few weeks. It stopped working when I rebooted after installing Sonoma 14.5. It always does this when I reboot, then it just starts working at some point.